aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA
diff options
context:
space:
mode:
Diffstat (limited to 'LUFA')
-rw-r--r--LUFA/Build/lufa_doxygen.mk2
-rw-r--r--LUFA/DoxygenPages/MigrationInformation.txt4
-rw-r--r--LUFA/doxyfile (renamed from LUFA/Doxygen.conf)0
-rw-r--r--LUFA/makefile2
4 files changed, 6 insertions, 2 deletions
diff --git a/LUFA/Build/lufa_doxygen.mk b/LUFA/Build/lufa_doxygen.mk
index a563bc1cf..babf28798 100644
--- a/LUFA/Build/lufa_doxygen.mk
+++ b/LUFA/Build/lufa_doxygen.mk
@@ -56,7 +56,7 @@ ERROR_IF_EMPTY ?= $(if $(strip $($(strip $(1)))), , $(error Makefile $(strip $
ERROR_IF_NONBOOL ?= $(if $(filter Y N, $($(strip $(1)))), , $(error Makefile $(strip $(1)) option must be Y or N))
# Default values of optionally user-supplied variables
-DOXYGEN_CONF ?= Doxygen.conf
+DOXYGEN_CONF ?= doxyfile
DOXYGEN_FAIL_ON_WARNING ?= Y
DOXYGEN_OVERRIDE_PARAMS ?= QUIET=YES HTML_EXTRA_STYLESHEET=$(patsubst %/,%,$(LUFA_PATH))/DoxygenPages/Style/Style.css
diff --git a/LUFA/DoxygenPages/MigrationInformation.txt b/LUFA/DoxygenPages/MigrationInformation.txt
index c9553e0a8..8d6cdb9dd 100644
--- a/LUFA/DoxygenPages/MigrationInformation.txt
+++ b/LUFA/DoxygenPages/MigrationInformation.txt
@@ -18,6 +18,10 @@
* <b>Non-USB Library Components</b>
* - The \c ATTR_NEVER_INLINE macro, erroneously introduced in a previous release has been removed, as it duplicates the existing \c ATTR_NO_INLINE macro.
*
+ * <b>Build System</b>
+ * - The default configuration file for Doxygen is now "doxyfile" rather than "Doxygen.conf", to conform to the Doxygen project's own default file name.
+ * Set \c DOXYGEN_CONF to override the new default file name.
+ *
* \section Sec_Migration130901 Migrating from 130303 to 130901
* <b>Non-USB Library Components</b>
* - The Board Dataflash \c Dataflash_Init() function now automatically configures the appropriate communication interface.
diff --git a/LUFA/Doxygen.conf b/LUFA/doxyfile
index f90329370..f90329370 100644
--- a/LUFA/Doxygen.conf
+++ b/LUFA/doxyfile
diff --git a/LUFA/makefile b/LUFA/makefile
index 51bad3cdb..88449a936 100644
--- a/LUFA/makefile
+++ b/LUFA/makefile
@@ -10,7 +10,7 @@
# ---------------------------------------
LUFA_VERSION_NUM = $(shell grep LUFA_VERSION_STRING $(LUFA_PATH)/Version.h | cut -d'"' -f2)
-EXCLUDE_FROM_EXPORT := Documentation DoxygenPages CodeTemplates Build StudioIntegration *.conf *.tar *.o *.d *.lss *.lst *.hex *.elf *.hex *.eep *.map *.bin
+EXCLUDE_FROM_EXPORT := Documentation DoxygenPages CodeTemplates Build StudioIntegration doxyfile *.tar *.o *.d *.lss *.lst *.hex *.elf *.hex *.eep *.map *.bin
# Default target - no default action when attempting to build the core directly
all: