aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA
diff options
context:
space:
mode:
Diffstat (limited to 'LUFA')
-rw-r--r--LUFA/Build/lufa_hid.mk12
-rw-r--r--LUFA/DoxygenPages/ChangeLog.txt7
-rw-r--r--LUFA/DoxygenPages/VIDAndPIDValues.txt2
-rw-r--r--LUFA/Drivers/Board/AVR8/U2S/Buttons.h2
-rw-r--r--LUFA/Drivers/Board/AVR8/U2S/LEDs.h2
-rw-r--r--LUFA/Drivers/USB/Class/Common/AudioClassCommon.h2
-rw-r--r--LUFA/Drivers/USB/Class/Common/CDCClassCommon.h2
7 files changed, 18 insertions, 11 deletions
diff --git a/LUFA/Build/lufa_hid.mk b/LUFA/Build/lufa_hid.mk
index a5a742deb..6755e3f3a 100644
--- a/LUFA/Build/lufa_hid.mk
+++ b/LUFA/Build/lufa_hid.mk
@@ -9,9 +9,9 @@
LUFA_BUILD_MODULES += HID
LUFA_BUILD_TARGETS += hid hid-ee teensy teensy-ee
LUFA_BUILD_MANDATORY_VARS += MCU TARGET
-LUFA_BUILD_OPTIONAL_VARS +=
-LUFA_BUILD_PROVIDED_VARS +=
-LUFA_BUILD_PROVIDED_MACROS +=
+LUFA_BUILD_OPTIONAL_VARS +=
+LUFA_BUILD_PROVIDED_VARS +=
+LUFA_BUILD_PROVIDED_MACROS +=
# -----------------------------------------------------------------------------
# LUFA HID Bootloader Buildsystem Makefile Module.
@@ -76,7 +76,7 @@ hid-ee: $(TARGET).eep $(MAKEFILE_LIST)
@echo $(MSG_OBJCPY_CMD) Converting \"$<\" to a binary file \"InputEEData.bin\"
avr-objcopy -I ihex -O binary $< $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/InputEEData.bin
@echo $(MSG_MAKE_CMD) Making EEPROM loader application for \"$<\"
- make -C $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/ MCU=$(MCU) clean hid
+ $(MAKE) -C $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/ MCU=$(MCU) clean hid
# Programs in the target FLASH memory using the TEENSY_BOOTLOADER_CLI tool
teensy: $(TARGET).hex $(MAKEFILE_LIST)
@@ -88,7 +88,7 @@ teensy-ee: $(TARGET).hex $(MAKEFILE_LIST)
@echo $(MSG_OBJCPY_CMD) Converting \"$<\" to a binary file \"InputEEData.bin\"
avr-objcopy -I ihex -O binary $< $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/InputEEData.bin
@echo $(MSG_MAKE_CMD) Making EEPROM loader application for \"$<\"
- make -s -C $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/ MCU=$(MCU) clean hid-teensy
-
+ $(MAKE) -s -C $(patsubst %/,%,$(LUFA_PATH))/Build/HID_EEPROM_Loader/ MCU=$(MCU) clean hid-teensy
+
# Phony build targets for this module
.PHONY: hid hid-ee teensy teensy-ee
diff --git a/LUFA/DoxygenPages/ChangeLog.txt b/LUFA/DoxygenPages/ChangeLog.txt
index 86ee08aef..29f6a6417 100644
--- a/LUFA/DoxygenPages/ChangeLog.txt
+++ b/LUFA/DoxygenPages/ChangeLog.txt
@@ -7,9 +7,16 @@
/** \page Page_ChangeLog Project Changelog
*
* \section Sec_ChangeLogXXXXXX Version XXXXXX
+ * <b>New:</b>
+ * - Library Applications:
+ * - Added new Bulk Vendor low level device demo
+ *
* <b>Changed:</b>
* - Library Applications:
* - Refactored out USB interface IDs in the demo applications into enums (thanks to Laszlo Monda)
+ * - AVRISP-MKII Clone Project PDI/TPI frequency increased from 250KHz to 2MHz as it is now stable
+ * - Fixed incorrect signature bytes returned in the DFU bootloader
+ * - Added new libUSB host Python application example for the class driver GenericHID demo (thanks to Laszlo Monda)
*
* \section Sec_ChangeLog130901 Version 130901
* <b>New:</b>
diff --git a/LUFA/DoxygenPages/VIDAndPIDValues.txt b/LUFA/DoxygenPages/VIDAndPIDValues.txt
index b31f007bb..6d39ce7f9 100644
--- a/LUFA/DoxygenPages/VIDAndPIDValues.txt
+++ b/LUFA/DoxygenPages/VIDAndPIDValues.txt
@@ -171,7 +171,7 @@
* <tr>
* <td>0x03EB</td>
* <td>0x206C</td>
- * <td><i>Currently Unallocated</i></td>
+ * <td>Bulk Vendor Demo</td>
* </tr>
* <tr>
* <td>0x03EB</td>
diff --git a/LUFA/Drivers/Board/AVR8/U2S/Buttons.h b/LUFA/Drivers/Board/AVR8/U2S/Buttons.h
index b414bc99a..b3d014a34 100644
--- a/LUFA/Drivers/Board/AVR8/U2S/Buttons.h
+++ b/LUFA/Drivers/Board/AVR8/U2S/Buttons.h
@@ -29,7 +29,7 @@
*/
/** \file
- * \brief Board specific Buttons driver header for the Mattairtech JM-DB-U2.
+ * \brief Board specific Buttons driver header for the U2S.
* \copydetails Group_Buttons_U2S
*
* \note This file should not be included directly. It is automatically included as needed by the Buttons driver
diff --git a/LUFA/Drivers/Board/AVR8/U2S/LEDs.h b/LUFA/Drivers/Board/AVR8/U2S/LEDs.h
index 2cc36ede7..51472b4f3 100644
--- a/LUFA/Drivers/Board/AVR8/U2S/LEDs.h
+++ b/LUFA/Drivers/Board/AVR8/U2S/LEDs.h
@@ -29,7 +29,7 @@
*/
/** \file
- * \brief Board specific LED driver header for the Tempusdictum Benito.
+ * \brief Board specific LED driver header for the U2S.
* \copydetails Group_LEDs_U2S
*
* \note This file should not be included directly. It is automatically included as needed by the LEDs driver
diff --git a/LUFA/Drivers/USB/Class/Common/AudioClassCommon.h b/LUFA/Drivers/USB/Class/Common/AudioClassCommon.h
index 6e4087305..bd74dedb7 100644
--- a/LUFA/Drivers/USB/Class/Common/AudioClassCommon.h
+++ b/LUFA/Drivers/USB/Class/Common/AudioClassCommon.h
@@ -618,7 +618,7 @@
/** \brief 24-Bit Audio Frequency Structure.
*
- * Type define for a 24bit audio sample frequency structure. As GCC does not contain a built in 24-bit datatype,
+ * Type define for a 24-bit audio sample frequency structure. As GCC does not contain a built in 24-bit datatype,
* this this structure is used to build up the value instead. Fill this structure with the \ref AUDIO_SAMPLE_FREQ() macro.
*
* \note Regardless of CPU architecture, these values should be stored as little endian.
diff --git a/LUFA/Drivers/USB/Class/Common/CDCClassCommon.h b/LUFA/Drivers/USB/Class/Common/CDCClassCommon.h
index 5f451b0d3..5a862f20a 100644
--- a/LUFA/Drivers/USB/Class/Common/CDCClassCommon.h
+++ b/LUFA/Drivers/USB/Class/Common/CDCClassCommon.h
@@ -289,7 +289,7 @@
* must be \ref CDC_DSUBTYPE_CSInterface_ACM.
*/
uint8_t Capabilities; /**< Capabilities of the ACM interface, given as a bit mask. For most devices,
- * this should be set to a fixed value of 0x06 - for other capabilities, refer
+ * this should be set to a fixed value of \c 0x06 - for other capabilities, refer
* to the CDC ACM specification.
*/
} ATTR_PACKED USB_CDC_Descriptor_FunctionalACM_t;