aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Mikromedia-STM32-M4-ILI9341
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-11-27 10:13:23 +1000
committerinmarket <andrewh@inmarket.com.au>2015-11-27 10:13:23 +1000
commit739b3b16993d2abee681b6070d5bb36b16b12444 (patch)
tree49ba5fc5134f13a9fa263087476a1317b5c4711c /boards/base/Mikromedia-STM32-M4-ILI9341
parentfb7e7c6ea7a8bd8501805a24d76e58ee617cdbe3 (diff)
downloaduGFX-739b3b16993d2abee681b6070d5bb36b16b12444.tar.gz
uGFX-739b3b16993d2abee681b6070d5bb36b16b12444.tar.bz2
uGFX-739b3b16993d2abee681b6070d5bb36b16b12444.zip
Update some makefiles and openocd config files
Diffstat (limited to 'boards/base/Mikromedia-STM32-M4-ILI9341')
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile1
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/openocd.cfg12
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_3.x/openocd.cfg12
3 files changed, 13 insertions, 12 deletions
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
index 7eb8eb3e..69eb7d59 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
@@ -20,6 +20,7 @@
# ChibiOS settings
ifeq ($(OPT_OS),chibios)
# See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
+ CHIBIOS_VERSION = 2
CHIBIOS = ../ChibiOS
CHIBIOS_BOARD =
CHIBIOS_PLATFORM = STM32F4xx
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/openocd.cfg b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/openocd.cfg
index f8b6a6f5..83395e5a 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/openocd.cfg
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/openocd.cfg
@@ -32,11 +32,11 @@ source [find interface/stlink-v2.cfg]
echo ""
echo "##### Loading CPU..."
-source [find target/stm32f4x_stlink.cfg]
+source [find target/stm32f4x.cfg]
echo ""
echo "##### Configuring..."
-reset_config srst_only srst_nogate
+#reset_config srst_only srst_nogate
#cortex_m maskisr (auto|on|off)
#cortex_m vector_catch [all|none|list]
#cortex_m reset_config (srst|sysresetreq|vectreset)
@@ -58,10 +58,10 @@ proc Burn {file} {
# If this happens to you - use the ST-Link utility to set the option byte back to normal.
# If you are using a different debugger eg a FT2232 based adapter you can uncomment the line below.
#stm32f2x unlock 0
- flash protect 0 0 last off
- reset init
- flash write_image erase $file 0x08000000
- verify_image $file 0x0
+ #flash protect 0 0 last off
+ reset halt
+ flash write_image erase $file 0 elf
+ verify_image $file 0x0 elf
#flash protect 0 0 last on
reset
echo "Burning Complete!"
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_3.x/openocd.cfg b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_3.x/openocd.cfg
index f8b6a6f5..83395e5a 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_3.x/openocd.cfg
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_3.x/openocd.cfg
@@ -32,11 +32,11 @@ source [find interface/stlink-v2.cfg]
echo ""
echo "##### Loading CPU..."
-source [find target/stm32f4x_stlink.cfg]
+source [find target/stm32f4x.cfg]
echo ""
echo "##### Configuring..."
-reset_config srst_only srst_nogate
+#reset_config srst_only srst_nogate
#cortex_m maskisr (auto|on|off)
#cortex_m vector_catch [all|none|list]
#cortex_m reset_config (srst|sysresetreq|vectreset)
@@ -58,10 +58,10 @@ proc Burn {file} {
# If this happens to you - use the ST-Link utility to set the option byte back to normal.
# If you are using a different debugger eg a FT2232 based adapter you can uncomment the line below.
#stm32f2x unlock 0
- flash protect 0 0 last off
- reset init
- flash write_image erase $file 0x08000000
- verify_image $file 0x0
+ #flash protect 0 0 last off
+ reset halt
+ flash write_image erase $file 0 elf
+ verify_image $file 0x0 elf
#flash protect 0 0 last on
reset
echo "Burning Complete!"