aboutsummaryrefslogtreecommitdiffstats
path: root/demos/modules/gwin/graph
diff options
context:
space:
mode:
Diffstat (limited to 'demos/modules/gwin/graph')
-rw-r--r--demos/modules/gwin/graph/demo.mk3
-rw-r--r--demos/modules/gwin/graph/gfxconf.h4
2 files changed, 7 insertions, 0 deletions
diff --git a/demos/modules/gwin/graph/demo.mk b/demos/modules/gwin/graph/demo.mk
new file mode 100644
index 00000000..c602c83e
--- /dev/null
+++ b/demos/modules/gwin/graph/demo.mk
@@ -0,0 +1,3 @@
+DEMODIR = $(GFXLIB)/demos/modules/gwin/graph
+GFXINC += $(DEMODIR)
+GFXSRC += $(DEMODIR)/main.c
diff --git a/demos/modules/gwin/graph/gfxconf.h b/demos/modules/gwin/graph/gfxconf.h
index c09bfc6e..bc65beea 100644
--- a/demos/modules/gwin/graph/gfxconf.h
+++ b/demos/modules/gwin/graph/gfxconf.h
@@ -39,6 +39,7 @@
/* GFX sub-systems to turn on */
#define GFX_USE_GDISP TRUE
#define GFX_USE_GWIN TRUE
+#define GFX_USE_GMISC TRUE
/* Features for the GDISP sub-system. */
#define GDISP_NEED_VALIDATION TRUE
@@ -48,5 +49,8 @@
#define GWIN_NEED_WINDOWMANAGER TRUE
#define GWIN_NEED_GRAPH TRUE
+/* Features for the GMISC subsystem. */
+#define GMISC_NEED_FASTTRIG TRUE
+
#endif /* _GFXCONF_H */