aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/SSD1289/readme.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gdisp/SSD1289/readme.txt')
-rw-r--r--drivers/gdisp/SSD1289/readme.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/drivers/gdisp/SSD1289/readme.txt b/drivers/gdisp/SSD1289/readme.txt
deleted file mode 100644
index 80d2bdab..00000000
--- a/drivers/gdisp/SSD1289/readme.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-To use this driver:
-
-1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
-
- b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
-
- c) If you are not using a known board then create a gdisp_lld_board.h file
- and ensure it is on your include path.
- Use the gdisp_lld_board_example.h or gdisp_lld_board_fsmc.h file as a basis.
- Currently known boards are:
- BOARD_FIREBULL_STM32_F103 - GPIO interface: requires GDISP_CMD_PORT and GDISP_DATA_PORT to be defined
- BOARD_ST_STM32F4_DISCOVERY - FSMC interface
-
- d) The following are optional - define them if you are not using the defaults below:
- #define GDISP_SCREEN_WIDTH 320
- #define GDISP_SCREEN_HEIGHT 240
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/SSD1289/gdisp_lld.mk