aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/SSD1289/readme.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gdisp/SSD1289/readme.txt')
-rw-r--r--drivers/gdisp/SSD1289/readme.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/drivers/gdisp/SSD1289/readme.txt b/drivers/gdisp/SSD1289/readme.txt
new file mode 100644
index 00000000..17d22223
--- /dev/null
+++ b/drivers/gdisp/SSD1289/readme.txt
@@ -0,0 +1,16 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define HAL_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ c) One (only) of:
+ #define LCD_USE_GPIO
+ #define LCD_USE_SPI
+ #define LCD_USE_FSMC
+ d) All of the following (with appropriate values):
+ #define SCREEN_WIDTH 320
+ #define SCREEN_HEIGHT 240
+
+2. To your makefile add the following lines:
+ include $(CHIBIOS)/os/halext/halext.mk
+ include $(CHIBIOS)/os/halext/drivers/gdispSsd1289/gdisp_lld.mk