aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/TestStub/readme.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gdisp/TestStub/readme.txt')
-rw-r--r--drivers/gdisp/TestStub/readme.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/drivers/gdisp/TestStub/readme.txt b/drivers/gdisp/TestStub/readme.txt
new file mode 100644
index 00000000..11145290
--- /dev/null
+++ b/drivers/gdisp/TestStub/readme.txt
@@ -0,0 +1,16 @@
+This low level driver is a test stub that doesn't talk to any
+real hardware. It is included to allow testing of the compilation
+process.
+
+Do not use this driver as a template for new drivers. Use the
+ templates/gdispXXXXX directory for that.
+
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h)
+ you want to compile test eg: GDISP_NEED_MULTITHREAD
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/gdisp/TestStub/gdisp_lld.mk