aboutsummaryrefslogtreecommitdiffstats
path: root/tools/file2c/source/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/file2c/source/Makefile')
-rw-r--r--tools/file2c/source/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/file2c/source/Makefile b/tools/file2c/source/Makefile
new file mode 100644
index 00000000..a6a7041c
--- /dev/null
+++ b/tools/file2c/source/Makefile
@@ -0,0 +1,15 @@
+TARGET = file2c
+SRCS = $(shell find -name '*.c')
+OBJS = $(addsuffix .o,$(basename $(SRCS)))
+
+CFLAGS = -Wall -p
+
+CC = /usr/bin/gcc
+RM = /bin/rm -f
+
+all: clean
+ $(CC) $(CFLAGS) -o $(TARGET) $(SRCS)
+
+clean:
+ $(RM) $(TARGET) $(OBJS)
+