aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/gmake_scripts/cpu_stm32m1.mk2
-rw-r--r--tools/gmake_scripts/cpu_stm32m3.mk2
-rw-r--r--tools/gmake_scripts/cpu_stm32m4.mk4
-rw-r--r--tools/gmake_scripts/cpu_stm32m7.mk2
-rw-r--r--tools/mcufontencoder/src/datafile.hh2
-rw-r--r--tools/mcufontencoder/src/main.cc2
6 files changed, 8 insertions, 6 deletions
diff --git a/tools/gmake_scripts/cpu_stm32m1.mk b/tools/gmake_scripts/cpu_stm32m1.mk
index 9c8246e6..777ae4f2 100644
--- a/tools/gmake_scripts/cpu_stm32m1.mk
+++ b/tools/gmake_scripts/cpu_stm32m1.mk
@@ -16,5 +16,5 @@
SRCFLAGS += -mcpu=cortex-m1 -falign-functions=16
LDFLAGS += -mcpu=cortex-m1
-DEFS += CORTEX_USE_FPU=FALSE
+DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m3.mk b/tools/gmake_scripts/cpu_stm32m3.mk
index 87030aee..b430d7fd 100644
--- a/tools/gmake_scripts/cpu_stm32m3.mk
+++ b/tools/gmake_scripts/cpu_stm32m3.mk
@@ -16,5 +16,5 @@
SRCFLAGS += -mcpu=cortex-m3 -falign-functions=16
LDFLAGS += -mcpu=cortex-m3
-DEFS += CORTEX_USE_FPU=FALSE
+DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m4.mk b/tools/gmake_scripts/cpu_stm32m4.mk
index 1e205eb6..db1efd07 100644
--- a/tools/gmake_scripts/cpu_stm32m4.mk
+++ b/tools/gmake_scripts/cpu_stm32m4.mk
@@ -16,9 +16,9 @@
SRCFLAGS += -mcpu=cortex-m4 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
LDFLAGS += -mcpu=cortex-m4 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
-DEFS += CORTEX_USE_FPU=TRUE USE_FPU=hard
+DEFS += CORTEX_USE_FPU=GFXON USE_FPU=hard
LIBS += m
#SRCFLAGS += -mcpu=cortex-m4 -falign-functions=16
#LDFLAGS += -mcpu=cortex-m4
-#DEFS += CORTEX_USE_FPU=FALSE
+#DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m7.mk b/tools/gmake_scripts/cpu_stm32m7.mk
index 78e1cc4e..c2d17b72 100644
--- a/tools/gmake_scripts/cpu_stm32m7.mk
+++ b/tools/gmake_scripts/cpu_stm32m7.mk
@@ -15,5 +15,5 @@
#
SRCFLAGS += -mcpu=cortex-m7 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
LDFLAGS += -mcpu=cortex-m7 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
-DEFS += CORTEX_USE_FPU=TRUE USE_FPU=hard
+DEFS += CORTEX_USE_FPU=GFXON USE_FPU=hard
LIBS += m \ No newline at end of file
diff --git a/tools/mcufontencoder/src/datafile.hh b/tools/mcufontencoder/src/datafile.hh
index 460e6039..b5e1d538 100644
--- a/tools/mcufontencoder/src/datafile.hh
+++ b/tools/mcufontencoder/src/datafile.hh
@@ -51,6 +51,8 @@ public:
DataFile(const std::vector<dictentry_t> &dictionary,
const std::vector<glyphentry_t> &glyphs,
const fontinfo_t &fontinfo);
+
+ inline DataFile * clone() const { return new DataFile(GetDictionary(), GetGlyphTable(), GetFontInfo()); }
// Save to a file (custom format)
void Save(std::ostream &file) const;
diff --git a/tools/mcufontencoder/src/main.cc b/tools/mcufontencoder/src/main.cc
index 70cd9132..a51b7451 100644
--- a/tools/mcufontencoder/src/main.cc
+++ b/tools/mcufontencoder/src/main.cc
@@ -443,7 +443,7 @@ static const char *usage_msg =
" rlefont_show_encoded <datfile> Show the encoded data for debugging.\n"
"\n"
"Commands specific to bwfont format:\n"
- " bwfont_export <datfile> [outfile Export to .c source code.\n"
+ " bwfont_export <datfile> [outfile] Export to .c source code.\n"
"";
typedef status_t (*cmd_t)(const std::vector<std::string> &args);