aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--AUTHORS.rst2
-rw-r--r--setup.py44
3 files changed, 48 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 2bf40e7c..886683e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,6 @@ _build/
.tox/
*.egg-info/
.coverage
+cffi-*.egg/
+pycparser-*.egg/
+pytest-*.egg/
diff --git a/AUTHORS.rst b/AUTHORS.rst
index 06e23d1f..3438aa04 100644
--- a/AUTHORS.rst
+++ b/AUTHORS.rst
@@ -5,3 +5,5 @@ AUTHORS
* Hynek Schlawack <hs@ox.cx>
* Donald Stufft <donald@stufft.io>
* Laurens Van Houtven <_@lvh.io>
+* Christian Heimes <christian@python.org>
+
diff --git a/setup.py b/setup.py
index c3b754f3..2b935340 100644
--- a/setup.py
+++ b/setup.py
@@ -11,11 +11,53 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+import sys
from setuptools import setup
+from setuptools.command.test import test as TestCommand
+
+
+class PyTest(TestCommand):
+ def finalize_options(self):
+ TestCommand.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+
+ def run_tests(self):
+ import pytest
+ errno = pytest.main(self.test_args)
+ sys.exit(errno)
setup(
name="cryptography",
+ description="cryptography is a package designed to expose cryptographic "
+ "primitives and recipes to Python developers.",
license="Apache License, Version 2.0",
- install_requires=["cffi>=0.6"],
+ url="https://github.com/alex/cryptography",
+ zip_safe=False, # for cffi
+ setup_requires=["cffi>=0.6"],
+ tests_require=["pytest"],
+ cmdclass = {"test": PyTest},
+ classifiers=[
+ "Development Status :: 2 - Pre-Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Natural Language :: English",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: POSIX",
+ "Operating System :: POSIX :: BSD",
+ "Operating System :: POSIX :: Linux",
+ "Operating System :: Microsoft :: Windows",
+ #"Programming Language :: cffi",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Security :: Cryptography",
+ ],
)