aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1856cadb..3202f843 100644
--- a/setup.py
+++ b/setup.py
@@ -10,12 +10,16 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import os
+
from setuptools import setup, find_packages
+base_dir = os.path.dirname(__file__)
+
about = {}
-with open("cryptography/__about__.py") as fp:
- exec(fp.read(), about)
+with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
+ exec(f.read(), about)
CFFI_DEPENDENCY = "cffi>=0.6"
@@ -30,11 +34,16 @@ setup_requires = [
CFFI_DEPENDENCY,
]
+with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
+
setup(
name=about["__title__"],
version=about["__version__"],
description=about["__summary__"],
+ long_description=long_description,
license=about["__license__"],
url=about["__uri__"],