aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.travis/install.sh8
-rw-r--r--dev-requirements.txt2
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 7 insertions, 7 deletions
diff --git a/.travis/install.sh b/.travis/install.sh
index 63d55ed3..112add24 100755
--- a/.travis/install.sh
+++ b/.travis/install.sh
@@ -38,8 +38,8 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv global 3.5.0
;;
pypy)
- pyenv install pypy-4.0.0
- pyenv global pypy-4.0.0
+ pyenv install pypy-4.0.1
+ pyenv global pypy-4.0.1
;;
pypy3)
pyenv install pypy3-2.4.0
@@ -60,8 +60,8 @@ else
PYENV_ROOT="$HOME/.pyenv"
PATH="$PYENV_ROOT/bin:$PATH"
eval "$(pyenv init -)"
- pyenv install pypy-4.0.0
- pyenv global pypy-4.0.0
+ pyenv install pypy-4.0.1
+ pyenv global pypy-4.0.1
fi
pip install virtualenv
fi
diff --git a/dev-requirements.txt b/dev-requirements.txt
index c409ff92..9aca5dd4 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -7,7 +7,7 @@ iso8601
pep8-naming
pretend
pyasn1_modules
-pytest
+pytest!=2.8.4
requests
sphinx==1.3.1
sphinx_rtd_theme
diff --git a/setup.py b/setup.py
index 19f1e663..43fe17e7 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,7 @@ else:
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
- "pytest",
+ "pytest!=2.8.4",
"pretend",
"iso8601",
"hypothesis",
diff --git a/tox.ini b/tox.ini
index 63f1e4bd..cf899b74 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,7 +7,7 @@ deps =
coverage
iso8601
pretend
- pytest
+ pytest!=2.8.4
hypothesis>=1.11.4
pyasn1_modules
./vectors