aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--docs/installation.rst20
1 files changed, 19 insertions, 1 deletions
diff --git a/docs/installation.rst b/docs/installation.rst
index 7e7348e2..a2fc5b7c 100644
--- a/docs/installation.rst
+++ b/docs/installation.rst
@@ -22,8 +22,26 @@ to include the corresponding locations. For example:
C:\> set INCLUDE=C:\OpenSSL-1.0.1f-64bit\include;%INCLUDE%
C:\> pip install cryptography
+Building cryptography on Linux
+------------------------------
+
+``cryptography`` should build very easily on linux provided you have headers
+for the OpenSSL and libffi available on your system.
+
+For Ubuntu, the following command line will ensure this is the case:
+
+.. code-block:: console
+
+ sudo apt-get install libssl-dev libffi-dev
+
+You should now be able to build and install cryptography with the usual
+
+.. code-block:: console
+
+ python setup.py install
+
Using your own OpenSSL on Linux
--------------------------------
+...............................
Python links to OpenSSL for its own purposes and this can sometimes cause
problems when you wish to use a different version of OpenSSL with cryptography.