aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py1
-rw-r--r--tox.ini7
2 files changed, 1 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 1b7454ae..098a6bbb 100644
--- a/setup.py
+++ b/setup.py
@@ -57,7 +57,6 @@ else:
requirements.append("cffi>=1.4.1")
setup_requirements.append("cffi>=1.4.1")
-# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",
"pretend",
diff --git a/tox.ini b/tox.ini
index 5cba83ec..424dc5bb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,14 +2,9 @@
envlist = py26,py27,pypy,py33,py34,py35,docs,pep8,py3pep8
[testenv]
-# If you add a new dep here you probably need to add it in setup.py as well
deps =
coverage
- iso8601
- pretend
- pytest
- hypothesis>=1.11.4
- pyasn1_modules
+ .[test]
./vectors
passenv = ARCHFLAGS LDFLAGS CFLAGS INCLUDE LIB LD_LIBRARY_PATH USERNAME
commands =