aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.rst8
-rw-r--r--cryptography/hazmat/bindings/commoncrypto/secitem.py2
-rw-r--r--cryptography/hazmat/primitives/asymmetric/rsa.py3
-rw-r--r--tasks.py2
-rw-r--r--tests/hazmat/primitives/test_rsa.py5
5 files changed, 17 insertions, 3 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index d0629c24..a5025e12 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -11,6 +11,14 @@ Changelog
constructor. The ``salt_length`` should be passed to
:class:`~cryptography.hazmat.primitives.asymmetric.padding.PSS` instead.
+0.5.2 - 2014-07-09
+~~~~~~~~~~~~~~~~~~
+
+* Add
+ :class:`~cryptography.hazmat.backends.interfaces.TraditionalOpenSSLSerializationBackend`
+ support to :doc:`/hazmat/backends/multibackend`.
+* Fix compilation error on OS X 10.8 (Mountain Lion).
+
0.5.1 - 2014-07-07
~~~~~~~~~~~~~~~~~~
diff --git a/cryptography/hazmat/bindings/commoncrypto/secitem.py b/cryptography/hazmat/bindings/commoncrypto/secitem.py
index 4d7710bd..ac3dad3f 100644
--- a/cryptography/hazmat/bindings/commoncrypto/secitem.py
+++ b/cryptography/hazmat/bindings/commoncrypto/secitem.py
@@ -23,8 +23,6 @@ const CFTypeRef kSecAttrKeySizeInBits;
const CFTypeRef kSecAttrIsPermanent;
const CFTypeRef kSecAttrKeyTypeRSA;
const CFTypeRef kSecAttrKeyTypeDSA;
-const CFTypeRef kSecAttrKeyTypeEC;
-const CFTypeRef kSecAttrKeyTypeEC;
const CFTypeRef kSecUseKeychain;
"""
diff --git a/cryptography/hazmat/primitives/asymmetric/rsa.py b/cryptography/hazmat/primitives/asymmetric/rsa.py
index 15ec52ac..398b3763 100644
--- a/cryptography/hazmat/primitives/asymmetric/rsa.py
+++ b/cryptography/hazmat/primitives/asymmetric/rsa.py
@@ -402,3 +402,6 @@ class RSAPublicNumbers(object):
def public_key(self, backend):
return backend.load_rsa_public_numbers(self)
+
+ def __repr__(self):
+ return "<RSAPublicNumbers(e={0}, n={1})>".format(self._e, self._n)
diff --git a/tasks.py b/tasks.py
index 65e33aea..c9fdfa99 100644
--- a/tasks.py
+++ b/tasks.py
@@ -81,7 +81,7 @@ def release(version):
"""
``version`` should be a string like '0.4' or '1.0'.
"""
- invoke.run("git tag -s {0}".format(version))
+ invoke.run("git tag -s {0} -m '{0} release'".format(version))
invoke.run("git push --tags")
invoke.run("python setup.py sdist")
diff --git a/tests/hazmat/primitives/test_rsa.py b/tests/hazmat/primitives/test_rsa.py
index 8e850737..e53ff06b 100644
--- a/tests/hazmat/primitives/test_rsa.py
+++ b/tests/hazmat/primitives/test_rsa.py
@@ -27,6 +27,7 @@ from cryptography.exceptions import (
)
from cryptography.hazmat.primitives import hashes, interfaces
from cryptography.hazmat.primitives.asymmetric import padding, rsa
+from cryptography.hazmat.primitives.asymmetric.rsa import RSAPublicNumbers
from .fixtures_rsa import (
RSA_KEY_1024, RSA_KEY_1025, RSA_KEY_1026, RSA_KEY_1027, RSA_KEY_1028,
@@ -1973,3 +1974,7 @@ class TestRSANumbers(object):
n=33
)
).private_key(backend)
+
+ def test_public_number_repr(self):
+ num = RSAPublicNumbers(1, 1)
+ assert repr(num) == "<RSAPublicNumbers(e=1, n=1)>"