diff options
-rw-r--r-- | setup.py | 4 | ||||
-rw-r--r-- | tests/hypothesis/__init__.py | 4 |
2 files changed, 7 insertions, 1 deletions
@@ -61,9 +61,11 @@ test_requirements = [ "pytest", "pretend", "iso8601", - "hypothesis>=1.11.4", "pyasn1_modules", ] +if sys.version_info[:2] > (2, 6): + test_requirements.append("hypothesis>=1.11.4") + # If there's no vectors locally that probably means we are in a tarball and # need to go and get the matching vectors package from PyPi diff --git a/tests/hypothesis/__init__.py b/tests/hypothesis/__init__.py index 4b540884..0b344066 100644 --- a/tests/hypothesis/__init__.py +++ b/tests/hypothesis/__init__.py @@ -3,3 +3,7 @@ # for complete details. from __future__ import absolute_import, division, print_function + +import pytest +# hypothesis no longer supports Python 2.6 so we simply skip it there +pytest.importorskip("hypothesis") |