diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 3 insertions, 6 deletions
@@ -29,15 +29,12 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f: exec(f.read(), about) -SETUPTOOLS_DEPENDENCY = "setuptools" -CFFI_DEPENDENCY = "cffi>=0.8" -SIX_DEPENDENCY = "six>=1.4.1" VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__']) requirements = [ "pyasn1", - SIX_DEPENDENCY, - SETUPTOOLS_DEPENDENCY + "six>=1.4.1", + "setuptools" ] if sys.version_info < (3, 4): @@ -47,7 +44,7 @@ if sys.version_info < (3, 3): requirements.append("ipaddress") if platform.python_implementation() != "PyPy": - requirements.append(CFFI_DEPENDENCY) + requirements.append("cffi>=0.8") # If you add a new dep here you probably need to add it in the tox.ini as well test_requirements = [ |