aboutsummaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 19 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index 24f1ea51..78b8b4c6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,12 +1,14 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,docs,pep8,py3pep8
+envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8
[testenv]
+# If you add a new dep here you probably need to add it in setup.py as well
deps =
coverage
iso8601
pretend
pytest
+ ./vectors
commands =
coverage run --source=cryptography/,tests/ -m pytest --capture=no --strict {posargs}
coverage report -m
@@ -24,20 +26,32 @@ commands =
sphinx-build -W -b doctest -d {envtmpdir}/doctrees docs docs/_build/html
sphinx-build -W -b spelling docs docs/_build/html
+[testenv:docs-linkcheck]
+deps =
+ sphinx
+basepython = python2.7
+commands =
+ sphinx-build -W -b linkcheck docs docs/_build/html
+
# Temporarily disable coverage on pypy because of performance problems with
# coverage.py on pypy.
[testenv:pypy]
-commands = py.test --capture=no --strict {posargs}
+commands =
+ py.test --capture=no --strict {posargs}
[testenv:pep8]
-deps = flake8
+deps =
+ flake8
+ pep8-naming
commands = flake8 .
[testenv:py3pep8]
basepython = python3.3
-deps = flake8
+deps =
+ flake8
+ pep8-naming
commands = flake8 .
[flake8]
exclude = .tox,*.egg
-select = E,W,F
+select = E,W,F,N