aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libmproxy/cmdline.py11
-rwxr-xr-xrelease/osx-binaries13
-rw-r--r--release/release-checklist1
3 files changed, 19 insertions, 6 deletions
diff --git a/libmproxy/cmdline.py b/libmproxy/cmdline.py
index ec03d63e..054a8059 100644
--- a/libmproxy/cmdline.py
+++ b/libmproxy/cmdline.py
@@ -195,6 +195,11 @@ def common_options(parser):
version= "%(prog)s" + " " + version.VERSION
)
parser.add_argument(
+ '--shortversion',
+ action= 'version',
+ version= version.VERSION
+ )
+ parser.add_argument(
"--anticache",
action="store_true", dest="anticache", default=False,
@@ -451,9 +456,9 @@ def common_options(parser):
"--replay-ignore-payload-param",
action="append", dest="replay_ignore_payload_params", type=str,
help="""
- Request's payload parameters (application/x-www-form-urlencoded) to
- be ignored while searching for a saved flow to replay.
- Can be passed multiple times.
+ Request's payload parameters (application/x-www-form-urlencoded) to
+ be ignored while searching for a saved flow to replay.
+ Can be passed multiple times.
"""
)
diff --git a/release/osx-binaries b/release/osx-binaries
index 9945e471..8d37d74b 100755
--- a/release/osx-binaries
+++ b/release/osx-binaries
@@ -13,19 +13,28 @@
# To run, first install netlib and mitmproxy, then change into the pyinstaller
# directory, and then run this script.
-DST=/tmp/osx-mitmproxy
+TMPDIR=/tmp
+DST=$TMPDIR/osx-mitmproxy
MITMPROXY=~/mitmproxy/mitmproxy
PYINST_CMD="./pyinstaller.py -F --clean"
-rm -rf $DST
+rm -rf $TMPDIR/osx-mitmproxy*
mkdir -p $DST
rm -rf mitmproxy
rm -rf mitmdump
$PYINST_CMD $MITMPROXY/mitmproxy
+$MITMPROXY/mitmproxy --version || exit 1
cp mitmproxy/dist/mitmproxy $DST
$PYINST_CMD $MITMPROXY/mitmdump
+$MITMPROXY/mitmdump --version || exit 1
cp mitmdump/dist/mitmdump $DST
cshape $MITMPROXY/doc-src $DST/doc
+
+VBASE=osx-mitmproxy-`$MITMPROXY/mitmdump --shortversion 2>&1`
+mv $DST $TMPDIR/$VBASE
+TGZDST=$TMPDIR/$VBASE.tgz
+cd $TMPDIR
+tar -czvf $VBASE.tgz $VBASE
diff --git a/release/release-checklist b/release/release-checklist
index 31a1a48f..f3abaf6a 100644
--- a/release/release-checklist
+++ b/release/release-checklist
@@ -31,7 +31,6 @@
python ./setup.py sdist
mv ./dist/FILE ~/mitmproxy/www.mitmproxy.org/src/download
-
- Adjust links on www.mitmproxy.org
- Upload to pypi for each project: