aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml2
-rw-r--r--.travis.yml2
-rw-r--r--MANIFEST.in1
-rw-r--r--setup.py4
4 files changed, 6 insertions, 3 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 5e0f3813..9a0c0872 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -15,7 +15,7 @@ after_test:
- |
git clone https://github.com/mitmproxy/release.git ..\release
pip install -e ..\release
- python ..\release\rtool.py -p mitmproxy bdist
+ python ..\release\rtool.py -p netlib -p mitmproxy bdist
- ps: Get-ChildItem ..\release\dist\*.zip | ForEach { Push-AppveyorArtifact $_.FullName -FileName $_.Name }
deploy:
- provider: FTP
diff --git a/.travis.yml b/.travis.yml
index 7b124709..390e5e02 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -61,7 +61,7 @@ after_success:
brew install curl --with-libssh2
git clone https://github.com/mitmproxy/release.git ../release
pip install -e ../release
- python ../release/rtool.py -p mitmproxy bdist
+ python ../release/rtool.py -p netlib -p mitmproxy bdist
for f in ../release/dist/*
do
$(brew --prefix curl)/bin/curl -u $SNAPSHOT_AUTH --hostpubmd5 $SNAPSHOT_PUBKEY --retry 5 -T $f sftp://$SNAPSHOT_HOST/
diff --git a/MANIFEST.in b/MANIFEST.in
index 7073fb6d..eb921d43 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -3,5 +3,6 @@ include LICENSE CHANGELOG CONTRIBUTORS CONTRIBUTING.md README.rst
graft examples
graft test
prune test/tools
+prune docs
graft libmproxy
recursive-exclude * *.pyc *.pyo *.swo *.swp
diff --git a/setup.py b/setup.py
index 897906b5..a5963807 100644
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,8 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
long_description = f.read()
# Core dependencies
+# Do not use the "~=" compatible release specifier.
+# This will break `pip install` on systems with old setuptools versions.
deps = {
"netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
"tornado>=4.3.0, <4.4",
@@ -23,7 +25,7 @@ deps = {
"html2text==2015.11.4",
"construct>=2.5.2, <2.6",
"six>=1.10.0, <1.11",
- "lxml==3.4.4", # there are no Windows wheels for 3.5!
+ "lxml==3.4.4", # there are no Windows wheels for newer versions, so we pin this.
"Pillow>=3.0.0, <3.1",
"watchdog>=0.8.3, <0.9",
}