aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 85af963f..96fa74e5 100644
--- a/setup.py
+++ b/setup.py
@@ -15,17 +15,17 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
long_description = f.read()
deps = {
- "pyasn1~=0.1.9",
- "pyOpenSSL~=0.15.1",
- "cryptography~=1.1.0",
- "passlib~=1.6.5",
- "hpack~=2.0.1",
- "six~=1.10.0",
- "certifi>=2015.9.6.2", # no semver here - this should always be on the last release!
- "backports.ssl_match_hostname~=3.4.0.2",
+ "pyasn1>=0.1.9, <0.2",
+ "pyOpenSSL>=0.15.1, <0.16",
+ "cryptography>=1.1.1, <1.2",
+ "passlib>=1.6.5, <1.7",
+ "hpack>=2.0.1, <2.1",
+ "six>=1.10.0, <1.11",
+ "certifi>=2015.9.6.2", # no semver here - this should always be on the last release!
+ "backports.ssl_match_hostname>=3.4.0.2, <3.4.1",
}
if sys.version_info < (3, 0):
- deps.add("ipaddress~=1.0.15")
+ deps.add("ipaddress>=1.0.15, <1.1")
setup(
name="netlib",