aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--examples/dup_and_replay.py6
-rw-r--r--mitmproxy/ctx.py2
-rw-r--r--release/README.md8
-rw-r--r--release/README.mkd20
-rw-r--r--release/specs/mitmdump.spec2
-rw-r--r--release/specs/mitmproxy.spec2
6 files changed, 14 insertions, 26 deletions
diff --git a/examples/dup_and_replay.py b/examples/dup_and_replay.py
index b47bf951..55d6ce7b 100644
--- a/examples/dup_and_replay.py
+++ b/examples/dup_and_replay.py
@@ -1,7 +1,7 @@
-from mitmproxy import master
+from mitmproxy import ctx
def request(flow):
- f = master.duplicate_flow(flow)
+ f = ctx.master.state.duplicate_flow(flow)
f.request.path = "/changed"
- master.replay_request(f, block=True, run_scripthooks=False)
+ ctx.master.replay_request(f, block=True, run_scripthooks=False)
diff --git a/mitmproxy/ctx.py b/mitmproxy/ctx.py
index 4ecfe79b..adae8cf6 100644
--- a/mitmproxy/ctx.py
+++ b/mitmproxy/ctx.py
@@ -1,2 +1,2 @@
master = None # type: "mitmproxy.master.Master"
-log = None # type: "mitmproxy.controller.Log"
+log = None # type: "mitmproxy.log.Log"
diff --git a/release/README.md b/release/README.md
new file mode 100644
index 00000000..f3965a2c
--- /dev/null
+++ b/release/README.md
@@ -0,0 +1,8 @@
+# Release Checklist
+
+- Verify that all CI tests pass for current master
+- Tag the release, and push to Github
+- Wait for tag CI to complete
+- Download assets from snapshots.mitmproxy.org
+- Create release notice on Github
+- Upload wheel to pypi
diff --git a/release/README.mkd b/release/README.mkd
deleted file mode 100644
index c5505431..00000000
--- a/release/README.mkd
+++ /dev/null
@@ -1,20 +0,0 @@
-
-# Release policies
-
- - By default, every release is a new minor (`0.x`) release and it will be
- pushed for all three projects.
-
- - Only if an emergency bugfix is needed, we push a new `0.x.y` bugfix release
- for a single project. This matches with what we do in `setup.py`:
-
- "mitmproxy>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION)
-
-
-# Release Checklist
-
-- Verify that all CI tests pass for current master
-- Tag the release, and push to Github
-- Wait for tag CI to complete
-- Download assets from snapshots.mitmproxy.org
-- Create release notice on Github
-- Upload wheel to pypi
diff --git a/release/specs/mitmdump.spec b/release/specs/mitmdump.spec
index fc145185..5314137d 100644
--- a/release/specs/mitmdump.spec
+++ b/release/specs/mitmdump.spec
@@ -4,7 +4,7 @@ from PyInstaller.utils.hooks import collect_data_files
a = Analysis(['mitmdump'],
binaries=None,
- datas=collect_data_files("mitmproxy.onboarding"),
+ datas=collect_data_files("mitmproxy.addons.onboardingapp"),
hiddenimports=[],
hookspath=None,
runtime_hooks=None,
diff --git a/release/specs/mitmproxy.spec b/release/specs/mitmproxy.spec
index f7ea99f9..b0141e5e 100644
--- a/release/specs/mitmproxy.spec
+++ b/release/specs/mitmproxy.spec
@@ -4,7 +4,7 @@ from PyInstaller.utils.hooks import collect_data_files
a = Analysis(['mitmproxy'],
binaries=None,
- datas=collect_data_files("mitmproxy.onboarding"),
+ datas=collect_data_files("mitmproxy.addons.onboardingapp"),
hiddenimports=[],
hookspath=None,
runtime_hooks=None,