aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py2
-rw-r--r--test/test_tcp.py3
2 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 2937487c..5ba9f824 100644
--- a/setup.py
+++ b/setup.py
@@ -88,5 +88,5 @@ setup(
"Topic :: Software Development :: Testing :: Traffic Generation",
"Topic :: Internet :: WWW/HTTP",
],
- install_requires=["pyasn1>0.1.2", "pyopenssl>=0.12"],
+ install_requires=["pyasn1>0.1.2", "pyopenssl>=0.14"],
)
diff --git a/test/test_tcp.py b/test/test_tcp.py
index 387e3f33..d5d11294 100644
--- a/test/test_tcp.py
+++ b/test/test_tcp.py
@@ -477,7 +477,6 @@ class TestFileLike:
tutils.raises(tcp.NetLibSSLError, s.read, 1)
-
class TestAddress:
def test_simple(self):
a = tcp.Address("localhost", True)
@@ -486,5 +485,3 @@ class TestAddress:
assert not a == b
c = tcp.Address("localhost", True)
assert a == c
-
-