aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml2
-rw-r--r--.travis.yml2
-rw-r--r--setup.py1
3 files changed, 3 insertions, 2 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 2e1a477f..6b3933f9 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -18,6 +18,8 @@ install:
- "python -c \"from OpenSSL import SSL; print(SSL.SSLeay_version(SSL.SSLEAY_VERSION))\""
test_script:
- "py.test --timeout 60 --cov netlib --cov mitmproxy --cov pathod"
+after_test:
+ - bash <(curl -s https://codecov.io/bash)
cache:
- C:\Users\appveyor\AppData\Local\pip\cache
deploy_script:
diff --git a/.travis.yml b/.travis.yml
index 87affb9b..1cb5075e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -52,7 +52,7 @@ script:
- "py.test --timeout 60 --cov netlib --cov mitmproxy --cov pathod test/$SCOPE"
after_success:
- - coveralls
+ - bash <(curl -s https://codecov.io/bash)
- |
if [[ $TRAVIS_OS_NAME == "osx" && $TRAVIS_PULL_REQUEST == "false" && ($TRAVIS_BRANCH == "master" || -n $TRAVIS_TAG) ]]
then
diff --git a/setup.py b/setup.py
index dd34465c..e8829d49 100644
--- a/setup.py
+++ b/setup.py
@@ -97,7 +97,6 @@ setup(
"ipaddress>=1.0.15, <1.1",
],
'dev': [
- "coveralls>=1.1, <1.2",
"mock>=2.0, <2.1",
"flake8>=2.5.4, <3",
"pytest>=2.8.7, <2.10",