aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 11 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index ec28eded..a03d74fb 100644
--- a/setup.py
+++ b/setup.py
@@ -64,23 +64,23 @@ setup(
"click>=6.2, <7",
"certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
"construct>=2.8, <2.9",
- "cryptography>=1.3, <1.9",
+ "cryptography>=1.4, <1.9",
"cssutils>=1.0.1, <1.1",
- "h2>=2.6.1, <3",
+ "h2>=3.0, <4",
"html2text>=2016.1.8, <=2016.9.19",
- "hyperframe>=4.0.2, <6",
+ "hyperframe>=5.0, <6",
"jsbeautifier>=1.6.3, <1.7",
- "kaitaistruct>=0.6, <0.7",
+ "kaitaistruct>=0.7, <0.8",
+ "ldap3>=2.2.0, <2.3",
"passlib>=1.6.5, <1.8",
"pyasn1>=0.1.9, <0.3",
- "pyOpenSSL>=16.0, <17.0",
+ "pyOpenSSL>=16.0, <17.1",
"pyparsing>=2.1.3, <2.3",
"pyperclip>=1.5.22, <1.6",
"requests>=2.9.1, <3",
- "ruamel.yaml>=0.13.2, <0.14",
- "tornado>=4.3, <4.5",
+ "ruamel.yaml>=0.13.2, <0.15",
+ "tornado>=4.3, <4.6",
"urwid>=1.3.1, <1.4",
- "watchdog>=0.8.3, <0.9",
"brotlipy>=0.5.1, <0.7",
"sortedcontainers>=1.5.4, <1.6",
# transitive from cryptography, we just blacklist here.
@@ -104,7 +104,7 @@ setup(
"pytest-timeout>=1.0.0, <2",
"pytest-xdist>=1.14, <2",
"pytest-faulthandler>=1.3.0, <2",
- "sphinx>=1.3.5, <1.6",
+ "sphinx>=1.3.5, <1.7",
"sphinx-autobuild>=0.5.2, <0.7",
"sphinxcontrib-documentedlist>=0.5.0, <0.7",
"sphinx_rtd_theme>=0.1.9, <0.3",
@@ -112,8 +112,8 @@ setup(
'contentviews': [
],
'examples': [
- "beautifulsoup4>=4.4.1, <4.6",
- "Pillow>=3.2, <4.1",
+ "beautifulsoup4>=4.4.1, <4.7",
+ "Pillow>=3.2, <4.2",
]
}
)