aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 10 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 564eb4d7..e0bd4545 100644
--- a/setup.py
+++ b/setup.py
@@ -2,13 +2,13 @@ from setuptools import setup, find_packages
from codecs import open
import os
+from netlib import version
+
# Based on https://github.com/pypa/sampleproject/blob/master/setup.py
# and https://python-packaging-user-guide.readthedocs.org/
here = os.path.abspath(os.path.dirname(__file__))
-from netlib import version
-
with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
long_description = f.read()
@@ -32,6 +32,8 @@ setup(
"Programming Language :: Python",
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security",
@@ -66,13 +68,12 @@ setup(
"construct>=2.5.2, <2.6",
"cryptography>=1.3, <1.5",
"Flask>=0.10.1, <0.12",
- "h2>=2.3.1, <3",
+ "h2>=2.4.0, <3",
"html2text>=2016.1.8, <=2016.5.29",
"hyperframe>=4.0.1, <5",
"lxml>=3.5.0, <3.7",
- "Pillow>=3.2, <3.3",
+ "Pillow>=3.2, <3.4",
"passlib>=1.6.5, <1.7",
- "psutil>=4.2, <4.4",
"pyasn1>=0.1.9, <0.2",
"pyOpenSSL>=16.0, <17.0",
"pyparsing>=2.1.3, <2.2",
@@ -99,10 +100,10 @@ setup(
'dev': [
"tox>=2.3, <3",
"mock>=2.0, <2.1",
- "pytest>=2.8.7, <2.10",
- "pytest-cov>=2.2.1, <2.3",
- "pytest-timeout>=1.0.0, <1.1",
- "pytest-xdist>=1.14, <1.15",
+ "pytest>=2.8.7, <3",
+ "pytest-cov>=2.2.1, <3",
+ "pytest-timeout>=1.0.0, <2",
+ "pytest-xdist>=1.14, <2",
"sphinx>=1.3.5, <1.5",
"sphinx-autobuild>=0.5.2, <0.7",
"sphinxcontrib-documentedlist>=0.4.0, <0.5",