diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -66,25 +66,25 @@ setup( "Brotli>=1.0,<1.1", "certifi>=2019.9.11", # no semver here - this should always be on the last release! "click>=7.0,<8", - "cryptography>=2.1.4,<2.5", + "cryptography>=2.9,<3.0", "flask>=1.1.1,<1.2", "h2>=3.2.0,<4", "hyperframe>=5.1.0,<6", "kaitaistruct>=0.7,<0.9", - "ldap3>=2.6.1,<2.7", + "ldap3>=2.6.1,<2.8", "passlib>=1.6.5, <1.8", - "protobuf>=3.6.0, <3.11", + "protobuf>=3.6.0, <3.12", "pyasn1>=0.3.1,<0.5", - "pyOpenSSL==19.0.0", + "pyOpenSSL>=19.1.0,<19.2", "pyparsing>=2.4.2,<2.5", - "pyperclip>=1.6.0,<1.8", + "pyperclip>=1.6.0,<1.9", "ruamel.yaml>=0.16,<0.17", "sortedcontainers>=2.1.0,<2.2", "tornado>=4.3,<7", "urwid>=2.1.0,<2.2", - "wsproto>=0.14.0,<0.15.0", + "wsproto>=0.14,<0.16", "publicsuffix2>=2.20190812,<3", - "zstandard>=0.11.0,<0.13.0", + "zstandard>=0.11,<0.14", ], extras_require={ ':sys_platform == "win32"': [ @@ -94,7 +94,7 @@ setup( "asynctest>=0.12.0", "flake8>=3.7.8,<3.8", "Flask>=1.0,<1.2", - "mypy>=0.740,<0.741", + "mypy>=0.740,<0.771", "parver>=0.1,<2.0", "pytest-asyncio>=0.10.0,<0.11", "pytest-cov>=2.7.1,<3", |