diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 5 insertions, 11 deletions
@@ -66,7 +66,6 @@ setup( "certifi>=2015.11.20.1", # no semver here - this should always be on the last release! "click>=6.2, <7", "cryptography>=2.1.4,<2.2", - 'h11>=0.7.0,<0.8', "h2>=3.0.1,<4", "hyperframe>=5.1.0,<6", "kaitaistruct>=0.7,<0.9", @@ -75,8 +74,7 @@ setup( "pyasn1>=0.3.1,<0.5", "pyOpenSSL>=17.5,<17.6", "pyparsing>=2.1.3, <2.3", - "pyperclip>=1.5.22, <1.7", - "requests>=2.9.1, <3", + "pyperclip>=1.6.0, <1.7", "ruamel.yaml>=0.13.2, <0.16", "sortedcontainers>=1.5.4, <1.6", "tornado>=4.3, <4.6", @@ -90,22 +88,18 @@ setup( 'dev': [ "flake8>=3.5, <3.6", "Flask>=0.10.1, <0.13", - "mypy>=0.560,<0.561", + "mypy>=0.570,<0.571", "pytest-cov>=2.5.1,<3", "pytest-faulthandler>=1.3.1,<2", "pytest-timeout>=1.2.1,<2", "pytest-xdist>=1.22,<2", "pytest>=3.3,<4", - "rstcheck>=2.2, <4.0", - "sphinx_rtd_theme>=0.1.9, <0.3", - "sphinx-autobuild>=0.5.2, <0.8", - "sphinx>=1.7,<1.8", - "sphinxcontrib-documentedlist>=0.5.0, <0.7", + "requests>=2.9.1, <3", "tox>=2.3, <3", + "rstcheck>=2.2, <4.0", ], 'examples': [ - "beautifulsoup4>=4.4.1, <4.7", - "Pillow>=4.3,<5.1", + "beautifulsoup4>=4.4.1, <4.7" ] } ) |