aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1b9e9648..7300edd1 100644
--- a/setup.py
+++ b/setup.py
@@ -68,7 +68,7 @@ setup(
"h2>=3.0.1,<4",
"hyperframe>=5.1.0,<6",
"kaitaistruct>=0.7,<0.9",
- "ldap3>=2.4,<2.5",
+ "ldap3>=2.5,<2.6",
"passlib>=1.6.5, <1.8",
"pyasn1>=0.3.1,<0.5",
"pyOpenSSL>=17.5,<17.6",
@@ -85,16 +85,18 @@ setup(
"pydivert>=2.0.3,<2.2",
],
'dev': [
+ "asynctest>=0.12.0",
"flake8>=3.5, <3.6",
- "Flask>=0.10.1, <0.13",
- "mypy>=0.580,<0.581",
+ "Flask>=1.0,<1.1",
+ "mypy>=0.590,<0.591",
+ "pytest-asyncio>=0.8",
"pytest-cov>=2.5.1,<3",
"pytest-faulthandler>=1.3.1,<2",
"pytest-timeout>=1.2.1,<2",
"pytest-xdist>=1.22,<2",
"pytest>=3.3,<4",
"requests>=2.9.1, <3",
- "tox>=2.3, <3",
+ "tox>=3.0,<3.1",
"rstcheck>=2.2, <4.0",
],
'examples': [