summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Mishchenko <alanmi@berkeley.edu>2015-04-04 16:36:11 +0700
committerAlan Mishchenko <alanmi@berkeley.edu>2015-04-04 16:36:11 +0700
commit6a0566d22b7e7a502f2583ed8b0d7d6399b1202e (patch)
tree8e552b6290c0df97b6d361852928e43b43e8228c
parentb79fd69fb56d051b4b85dd998daf9a1b07df1fb8 (diff)
downloadabc-6a0566d22b7e7a502f2583ed8b0d7d6399b1202e.tar.gz
abc-6a0566d22b7e7a502f2583ed8b0d7d6399b1202e.tar.bz2
abc-6a0566d22b7e7a502f2583ed8b0d7d6399b1202e.zip
Bug fix for big-endiang architectures (plus adding -lm in Makefile).
-rw-r--r--Makefile2
-rw-r--r--src/opt/ret/retIncrem.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 79b1e832..9296bd20 100644
--- a/Makefile
+++ b/Makefile
@@ -72,7 +72,7 @@ endif
endif
# LIBS := -ldl -lrt
-LIBS += -ldl
+LIBS += -ldl -lm
ifneq ($(findstring Darwin, $(shell uname)), Darwin)
LIBS += -lrt
endif
diff --git a/src/opt/ret/retIncrem.c b/src/opt/ret/retIncrem.c
index 0a44276d..9137f151 100644
--- a/src/opt/ret/retIncrem.c
+++ b/src/opt/ret/retIncrem.c
@@ -176,7 +176,7 @@ int Abc_NtkRetimeFinalizeLatches( Abc_Ntk_t * pNtk, st__table * tLatches, int nI
{
// this is an old latch
// get its number in the original order
- if ( ! st__lookup( tLatches, (char *)pLatch, (char **)&Index ) )
+ if ( ! st__lookup_int( tLatches, (char *)pLatch, &Index ) )
{
printf( "Abc_NtkRetimeFinalizeLatches(): Internal error.\n" );
return 0;