summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Milanović <mmicko@gmail.com>2022-07-27 14:08:06 +0200
committerGitHub <noreply@github.com>2022-07-27 14:08:06 +0200
commit7cc11f7f0c49d4ce7e0ed88950d1c4c8abb1cba4 (patch)
tree7993a84977bb1d5d567bfd66ae75414855e38264
parent4e89fc7ccb32086a55c2fbc567755c96e319d2f8 (diff)
parentb6c0b36c8aa0a181a541a8cc4320ebde938a0fe0 (diff)
downloadabc-7cc11f7f0c49d4ce7e0ed88950d1c4c8abb1cba4.tar.gz
abc-7cc11f7f0c49d4ce7e0ed88950d1c4c8abb1cba4.tar.bz2
abc-7cc11f7f0c49d4ce7e0ed88950d1c4c8abb1cba4.zip
Merge pull request #18 from josuah/yosys-experimental
provide a fallback for systems without RLIMIT_AS
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 27ede6ac..032f3a8d 100644
--- a/Makefile
+++ b/Makefile
@@ -137,11 +137,11 @@ endif
# LIBS := -ldl -lrt
LIBS += -lm
-ifneq ($(OS), FreeBSD)
+ifneq ($(OS), $(filter $(OS), FreeBSD OpenBSD))
LIBS += -ldl
endif
-ifneq ($(findstring Darwin, $(shell uname)), Darwin)
+ifneq ($(OS), $(filter $(OS), FreeBSD OpenBSD Darwin))
LIBS += -lrt
endif