summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Mishchenko <alanmi@berkeley.edu>2011-03-29 13:04:21 -0700
committerAlan Mishchenko <alanmi@berkeley.edu>2011-03-29 13:04:21 -0700
commit2b336851a2f748b213774094b96c7622f6001917 (patch)
tree67edfe3634b90296705bc66c60fdebffc2c415fa
parent6c01e8b9f040d591f72882aff08ed21446fbb567 (diff)
downloadabc-2b336851a2f748b213774094b96c7622f6001917.tar.gz
abc-2b336851a2f748b213774094b96c7622f6001917.tar.bz2
abc-2b336851a2f748b213774094b96c7622f6001917.zip
Added test package.
-rw-r--r--Makefile2
-rw-r--r--abclib.dsp8
-rw-r--r--src/aig/int/intCore.c1
-rw-r--r--src/base/abci/abc.c4
-rw-r--r--src/base/main/mainInit.c4
-rw-r--r--src/base/main/mainInt.h4
6 files changed, 19 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 94478fae..67c42696 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ PROG := abc
MODULES := \
$(wildcard src/ext) src/misc/ext \
src/base/abc src/base/abci src/base/cmd \
- src/base/io src/base/main src/base/ver \
+ src/base/io src/base/main src/base/ver src/base/test \
src/bdd/cudd src/bdd/dsd src/bdd/epd src/bdd/mtr \
src/bdd/parse src/bdd/reo src/bdd/cas \
src/map/fpga src/map/mapper src/map/mio src/map/super \
diff --git a/abclib.dsp b/abclib.dsp
index c48ac762..d98a8a91 100644
--- a/abclib.dsp
+++ b/abclib.dsp
@@ -4187,6 +4187,10 @@ SOURCE=.\src\aig\au\auDec6.c
# End Source File
# Begin Source File
+SOURCE=.\src\aig\au\auDiv.c
+# End Source File
+# Begin Source File
+
SOURCE=.\src\aig\au\auDsd.c
# End Source File
# Begin Source File
@@ -4239,6 +4243,10 @@ SOURCE=.\src\aig\au\auResDiv.c
# End Source File
# Begin Source File
+SOURCE=.\src\aig\au\auResTruth.c
+# End Source File
+# Begin Source File
+
SOURCE=.\src\aig\au\auSat.h
# End Source File
# Begin Source File
diff --git a/src/aig/int/intCore.c b/src/aig/int/intCore.c
index 646c83e1..fdc2241e 100644
--- a/src/aig/int/intCore.c
+++ b/src/aig/int/intCore.c
@@ -243,6 +243,7 @@ p->timeCnf += clock() - clk;
clk = clock();
if ( p->pInterNew )
{
+// Ioa_WriteAiger( p->pInterNew, "interpol.aig", 0, 0 );
p->pInterNew = Dar_ManRwsat( pAigTemp = p->pInterNew, 1, 0 );
// p->pInterNew = Dar_ManRwsat( pAigTemp = p->pInterNew, 0, 0 );
Aig_ManStop( pAigTemp );
diff --git a/src/base/abci/abc.c b/src/base/abci/abc.c
index b8c8f7a0..89d8cca3 100644
--- a/src/base/abci/abc.c
+++ b/src/base/abci/abc.c
@@ -8687,8 +8687,8 @@ int Abc_CommandTest( Abc_Frame_t * pAbc, int argc, char ** argv )
Aig_ManStop( pAig );
}
*/
-
/*
+
if ( Abc_NtkIsStrash(pNtk) )
{
extern Abc_Ntk_t * Au_ManTransformTest( Abc_Ntk_t * pAig );
@@ -8706,8 +8706,8 @@ int Abc_CommandTest( Abc_Frame_t * pAbc, int argc, char ** argv )
}
// replace the current network
Abc_FrameReplaceCurrentNetwork( pAbc, pNtkRes );
-*/
+*/
{
// extern void Au_Sat3DeriveImpls();
diff --git a/src/base/main/mainInit.c b/src/base/main/mainInit.c
index a6f4b9e1..c15ca872 100644
--- a/src/base/main/mainInit.c
+++ b/src/base/main/mainInit.c
@@ -46,6 +46,8 @@ extern void Libs_Init( Abc_Frame_t * pAbc );
extern void Libs_End( Abc_Frame_t * pAbc );
extern void Load_Init( Abc_Frame_t * pAbc );
extern void Load_End( Abc_Frame_t * pAbc );
+extern void Test_Init( Abc_Frame_t * pAbc );
+extern void Test_End( Abc_Frame_t * pAbc );
////////////////////////////////////////////////////////////////////////
/// FUNCTION DEFINITIONS ///
@@ -74,6 +76,7 @@ void Abc_FrameInit( Abc_Frame_t * pAbc )
Super_Init( pAbc );
Libs_Init( pAbc );
Load_Init( pAbc );
+ Test_Init( pAbc );
EXT_ABC_INIT(pAbc) // plugin for external functionality
}
@@ -100,6 +103,7 @@ void Abc_FrameEnd( Abc_Frame_t * pAbc )
Super_End( pAbc );
Libs_End( pAbc );
Load_End( pAbc );
+ Test_End( pAbc );
EXT_ABC_END(pAbc) // plugin for external functionality
}
diff --git a/src/base/main/mainInt.h b/src/base/main/mainInt.h
index 3eaa2978..d3a1fc9f 100644
--- a/src/base/main/mainInt.h
+++ b/src/base/main/mainInt.h
@@ -63,7 +63,9 @@ struct Abc_Frame_t_
st_table * tFlags; // the flag table
Vec_Ptr_t * aHistory; // the command history
// the functionality
- Abc_Ntk_t * pNtkCur; // the current network
+ Abc_Ntk_t * pNtkCur; // the current network
+ Abc_Ntk_t * pNtkBestDelay; // the current network
+ Abc_Ntk_t * pNtkBestArea; // the current network
int nSteps; // the counter of different network processed
int fAutoexac; // marks the autoexec mode
int fBatchMode; // are we invoked in batch mode?