summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBaruch Sterin <baruchs@gmail.com>2015-11-13 03:42:12 -0800
committerBaruch Sterin <baruchs@gmail.com>2015-11-13 03:42:12 -0800
commit2ac47fe5849ccacdf698406b2732505e6e1905c0 (patch)
tree61d348d5559cbc6a049ebccee4b212c4dc498bf9 /CMakeLists.txt
parent3237ebafaa36ccc114a4274ff9ca9f5dfe61821b (diff)
downloadabc-2ac47fe5849ccacdf698406b2732505e6e1905c0.tar.gz
abc-2ac47fe5849ccacdf698406b2732505e6e1905c0.tar.bz2
abc-2ac47fe5849ccacdf698406b2732505e6e1905c0.zip
CMake: make it possible to pass ABC_USE_NAMESPACE=FALSE, instead of just empty ABC_USE_NAMESPACE
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 977f0938..d3ac737b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,7 @@ elseif(READLINE_FOUND MATCHES FALSE)
endif()
if(ABC_USE_NAMESPACE)
- set(ABC_USE_NAMESPACE "ABC_USE_NAMESPACE=${ABC_USE_NAMESPACE}")
+ set(ABC_USE_NAMESPACE_FLAGS "ABC_USE_NAMESPACE=${ABC_USE_NAMESPACE}")
endif()
# run make to extract compiler options, linker options and list of source files
@@ -52,7 +52,7 @@ execute_process(
COMMAND
make
${ABC_READLINE_FLAGS}
- ${ABC_USE_NAMESPACE}
+ ${ABC_USE_NAMESPACE_FLAGS}
ARCHFLAGS_EXE=${CMAKE_CURRENT_BINARY_DIR}/abc_arch_flags_program.exe
ABC_MAKE_NO_DEPS=1
CC=${CMAKE_C_COMPILER}