summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBaruch Sterin <baruchs@gmail.com>2015-10-21 22:56:15 -0700
committerBaruch Sterin <baruchs@gmail.com>2015-10-21 22:56:15 -0700
commit9b3a358e6fba7ee6bd4811ed95f3c8c62e056152 (patch)
tree7f86a03f848f51a04b3cac754457afabe6f3fd97 /Makefile
parent28f2063caa7fb8864a63622a40f54bb70d1be08e (diff)
downloadabc-9b3a358e6fba7ee6bd4811ed95f3c8c62e056152.tar.gz
abc-9b3a358e6fba7ee6bd4811ed95f3c8c62e056152.tar.bz2
abc-9b3a358e6fba7ee6bd4811ed95f3c8c62e056152.zip
Makefile: Add a CMakeLists.txt that uses the regular Makefile to compute flags and source file. This is a ugly hack, mainly to allow the use of CLion with ABC. Include some changes in the Makefile to support that.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e1ba1500..03fceceb 100644
--- a/Makefile
+++ b/Makefile
@@ -125,7 +125,7 @@ CXXFLAGS += $(CFLAGS)
SRC :=
GARBAGE := core core.* *.stackdump ./tags $(PROG) arch_flags
-.PHONY: all default tags clean docs
+.PHONY: all default tags clean docs cmake_info
include $(patsubst %, %/module.make, $(MODULES))
@@ -163,7 +163,9 @@ DEP := $(OBJ:.o=.d)
@echo "$(MSG_PREFIX)\`\` Generating dependency:" $(LOCAL_PATH)/$<
$(VERBOSE)./depends.sh $(CXX) `dirname $*.cpp` $(OPTFLAGS) $(INCLUDES) $(CXXFLAGS) $*.cpp > $@
+ifndef ABC_MAKE_NO_DEPS
-include $(DEP)
+endif
# Actual targets
@@ -188,3 +190,8 @@ lib$(PROG).a: $(OBJ)
docs:
@echo "$(MSG_PREFIX)\`\` Building documentation." $(notdir $@)
$(VERBOSE)doxygen doxygen.conf
+
+cmake_info:
+ @echo SEPARATOR_CFLAGS $(CFLAGS) SEPARATOR_CFLAGS
+ @echo SEPARATOR_LIBS $(LIBS) SEPARATOR_LIBS
+ @echo SEPARATOR_SRC $(SRC) SEPARATOR_SRC