summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAlan Mishchenko <alanmi@berkeley.edu>2015-02-05 14:33:02 -0800
committerAlan Mishchenko <alanmi@berkeley.edu>2015-02-05 14:33:02 -0800
commitb537110cce3de9fc9ae9a180b3cc0d81d544de9e (patch)
treebcfe2bbd325db5120d91a679eea7dae2a9c288b6 /Makefile
parent8410daf3e49f142dc94587d77680d7cdcfe06b5a (diff)
downloadabc-b537110cce3de9fc9ae9a180b3cc0d81d544de9e.tar.gz
abc-b537110cce3de9fc9ae9a180b3cc0d81d544de9e.tar.bz2
abc-b537110cce3de9fc9ae9a180b3cc0d81d544de9e.zip
Change to Makefile to speedup compilation.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f7810619..c6907f71 100644
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@ default: $(PROG)
arch_flags : arch_flags.c
$(CC) arch_flags.c -o arch_flags
-ARCHFLAGS ?= $(shell $(CC) arch_flags.c -o arch_flags && ./arch_flags)
+ARCHFLAGS := $(shell $(CC) arch_flags.c -o arch_flags && ./arch_flags)
OPTFLAGS ?= -g -O #-DABC_NAMESPACE=xxx
CFLAGS += -Wall -Wno-unused-function -Wno-write-strings -Wno-sign-compare $(OPTFLAGS) $(ARCHFLAGS) -Isrc