summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authoralanminko <37236958+alanminko@users.noreply.github.com>2022-01-22 13:20:29 -0800
committerGitHub <noreply@github.com>2022-01-22 13:20:29 -0800
commitdf1f7198e05137e06f4f3eedb480dbf36085018f (patch)
tree033498284c82ff1411393d688758233ba9172761 /Makefile
parent5b8fa41ba966271f97f99860b21eee83bf51e61a (diff)
parentfd975af1595dbf8f8a703591dac7b5f0059925db (diff)
downloadabc-df1f7198e05137e06f4f3eedb480dbf36085018f.tar.gz
abc-df1f7198e05137e06f4f3eedb480dbf36085018f.tar.bz2
abc-df1f7198e05137e06f4f3eedb480dbf36085018f.zip
Merge pull request #150 from sterin/master
Move CI to GitHub Actions.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index bdea392a..3976cf7b 100644
--- a/Makefile
+++ b/Makefile
@@ -61,9 +61,9 @@ ifneq ($(findstring arm,$(shell uname -m)),)
CFLAGS += -DABC_MEMALIGN=4
endif
-# compile ABC using the C++ comipler and put everything in the namespace $(ABC_NAMESPACE)
+# compile ABC using the C++ compiler and put everything in the namespace $(ABC_NAMESPACE)
ifdef ABC_USE_NAMESPACE
- CFLAGS += -DABC_NAMESPACE=$(ABC_USE_NAMESPACE) -fpermissive
+ CFLAGS += -DABC_NAMESPACE=$(ABC_USE_NAMESPACE) -fpermissive -x c++
CC := $(CXX)
$(info $(MSG_PREFIX)Compiling in namespace $(ABC_NAMESPACE))
endif