summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAaron Tomb <atomb@galois.com>2013-11-06 16:35:59 -0800
committerAaron Tomb <atomb@galois.com>2013-11-06 16:35:59 -0800
commite8301980fe765e248d620cce76a5575c7ce53375 (patch)
tree040b32b397f8393bfbfbb50ad891d80ba67161f5 /Makefile
parent56378651c74e8815a091b13665a1f5dc809d816b (diff)
downloadabc-e8301980fe765e248d620cce76a5575c7ce53375.tar.gz
abc-e8301980fe765e248d620cce76a5575c7ce53375.tar.bz2
abc-e8301980fe765e248d620cce76a5575c7ce53375.zip
Allow ARCHFLAGS and OPTFLAGS to be overridden.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ca22379d..3b1890d1 100644
--- a/Makefile
+++ b/Makefile
@@ -38,8 +38,8 @@ default: $(PROG)
arch_flags : arch_flags.c
$(CC) arch_flags.c -o arch_flags
-ARCHFLAGS := $(shell $(CC) arch_flags.c -o arch_flags && ./arch_flags)
-OPTFLAGS := -g -O #-DABC_NAMESPACE=xxx
+ARCHFLAGS ?= $(shell $(CC) arch_flags.c -o arch_flags && ./arch_flags)
+OPTFLAGS ?= -g -O #-DABC_NAMESPACE=xxx
CFLAGS += -Wall -Wno-unused-function -Wno-write-strings -Wno-sign-compare $(OPTFLAGS) $(ARCHFLAGS) -I$(PWD)/src