summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c5d6989c..27b86a59 100644
--- a/Makefile
+++ b/Makefile
@@ -31,9 +31,9 @@ all: $(PROG)
default: $(PROG)
arch_flags : arch_flags.c
- gcc arch_flags.c -o arch_flags
+ $(CC) arch_flags.c -o arch_flags
-ARCHFLAGS := $(shell gcc arch_flags.c -o arch_flags && ./arch_flags)
+ARCHFLAGS := $(shell $(CC) arch_flags.c -o arch_flags && ./arch_flags)
OPTFLAGS := -g -O #-DABC_NAMESPACE=xxx
CFLAGS += -Wall -Wno-unused-function $(OPTFLAGS) $(ARCHFLAGS) -I$(PWD)
@@ -43,7 +43,7 @@ CXXFLAGS += $(CFLAGS)
LIBS := -lreadline
SRC :=
-GARBAGE := core core.* *.stackdump ./tags $(PROG)
+GARBAGE := core core.* *.stackdump ./tags $(PROG) arch_flags
.PHONY: tags clean docs