summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt10
-rw-r--r--README.md (renamed from readme.md)8
2 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3ac737b..7cf6f19a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,15 +88,17 @@ function(abc_properties target visibility)
target_link_libraries(${target} ${visibility} ${ABC_LIBS})
endfunction()
-add_executable(abc ${ABC_SRC})
-abc_properties(abc PRIVATE)
-
-list(REMOVE_ITEM ABC_SRC src/base/main/main.c)
+set(ABC_MAIN_SRC src/base/main/main.c)
+list(REMOVE_ITEM ABC_SRC ${ABC_MAIN_SRC})
add_library(libabc EXCLUDE_FROM_ALL ${ABC_SRC})
abc_properties(libabc PUBLIC)
set_property(TARGET libabc PROPERTY OUTPUT_NAME abc)
+add_executable(abc ${ABC_MAIN_SRC})
+target_link_libraries(abc PRIVATE libabc)
+abc_properties(abc PRIVATE)
+
add_library(libabc-pic EXCLUDE_FROM_ALL ${ABC_SRC})
abc_properties(libabc-pic PUBLIC)
set_property(TARGET libabc-pic PROPERTY POSITION_INDEPENDENT_CODE ON)
diff --git a/readme.md b/README.md
index d6773966..be02c72f 100644
--- a/readme.md
+++ b/README.md
@@ -66,11 +66,11 @@ The current version of ABC can be compiled with C compiler or C++ compiler.
## Bug reporting:
Please try to reproduce all the reported bugs and unexpected features using the latest
-version of ABC available from https://bitbucket.org/alanmi/abc/
+version of ABC available from https://github.com/berkeley-abc/abc
If the bug still persists, please provide the following information:
- 1. ABC version (when it was downloaded from BitBucket)
+ 1. ABC version (when it was downloaded from GitHub)
1. Linux distribution and version (32-bit or 64-bit)
1. The exact command-line and error message when trying to run the tool
1. The output of the `ldd` command run on the exeutable (e.g. `ldd abc`).
@@ -109,6 +109,4 @@ https://www.dropbox.com/s/qrl9svlf0ylxy8p/ABC_GettingStarted.pdf
Unfortunately, there is no comprehensive regression test. Good luck!
This system is maintained by Alan Mishchenko <alanmi@berkeley.edu>. Consider also
-using ZZ framework developed by Niklas Een: https://bitbucket.org/niklaseen/abc-zz
-
-This file was last modified on June 18, 2014
+using ZZ framework developed by Niklas Een: https://bitbucket.org/niklaseen/abc-zz (or https://github.com/berkeley-abc/abc-zz)