summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c47da11a..7d947959 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,3 +56,10 @@ endfunction()
add_executable(abc ${ABC_SRC})
abc_properties(abc PRIVATE)
+list(REMOVE_ITEM ABC_SRC src/base/main/main.c)
+
+add_library(libabc-pic EXCLUDE_FROM_ALL ${ABC_SRC})
+abc_properties(libabc-pic PUBLIC)
+
+set_property(TARGET libabc-pic PROPERTY POSITION_INDEPENDENT_CODE ON)
+set_property(TARGET libabc-pic PROPERTY OUTPUT_NAME abc-pic)