aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 69818ce0..a7200dd6 100644
--- a/Makefile
+++ b/Makefile
@@ -137,6 +137,7 @@ DEPENDS_ON_X86_PORT_IO := \
CONFIG_SATAMV \
DEPENDS_ON_LIBPCI := \
+ CONFIG_ASM106X \
CONFIG_ATAHPT \
CONFIG_ATAPROMISE \
CONFIG_ATAVIA \
@@ -437,6 +438,9 @@ CONFIG_GFXNVIDIA ?= yes
# Always enable SiI SATA controllers for now.
CONFIG_SATASII ?= yes
+# ASMedia ASM106x
+CONFIG_ASM106X ?= yes
+
# Highpoint (HPT) ATA/RAID controller support.
# IMPORTANT: This code is not yet working!
CONFIG_ATAHPT ?= no
@@ -642,6 +646,12 @@ PROGRAMMER_OBJS += satasii.o
ACTIVE_PROGRAMMERS += satasii
endif
+ifeq ($(CONFIG_ASM106X), yes)
+FEATURE_FLAGS += -D'CONFIG_ASM106X=1'
+PROGRAMMER_OBJS += asm106x.o
+ACTIVE_PROGRAMMERS += asm106x
+endif
+
ifeq ($(CONFIG_ATAHPT), yes)
FEATURE_FLAGS += -D'CONFIG_ATAHPT=1'
PROGRAMMER_OBJS += atahpt.o