aboutsummaryrefslogtreecommitdiffstats
path: root/bindings/rust/libflashrom/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/rust/libflashrom/Cargo.toml')
-rw-r--r--bindings/rust/libflashrom/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/bindings/rust/libflashrom/Cargo.toml b/bindings/rust/libflashrom/Cargo.toml
new file mode 100644
index 00000000..68636dff
--- /dev/null
+++ b/bindings/rust/libflashrom/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "libflashrom"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+libflashrom-sys = { path = "../libflashrom-sys" }
+libc = "0.2.124"
+regex = "1.5.5"
+once_cell = "1.7.2"
+
+[dev-dependencies]
+rusty-fork = "0.3.0"
+gag = "1"
+
+[build-dependencies]
+pkg-config = "0.3.19"
+cc = "1.0.72"