aboutsummaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/conf.py1
-rw-r--r--doc/meson.build6
2 files changed, 2 insertions, 5 deletions
diff --git a/doc/conf.py b/doc/conf.py
index d06f5386..79d8aaec 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -11,7 +11,6 @@ import os
project = 'flashrom'
# copyright = '2023, The flashrom authors'
author = 'The flashrom authors'
-release = os.getenv('FLASHROM_VERSION')
# -- General configuration ---------------------------------------------------
# https://www.sphinx-doc.org/en/master/usage/configuration.html#general-configuration
diff --git a/doc/meson.build b/doc/meson.build
index bdf4493f..8826e331 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -14,8 +14,7 @@ if sphinx.found()
custom_target(
'man-pages',
- command : [sphinx, '-b', 'man', '-q', '-d', '@PRIVATE_DIR@', '@CURRENT_SOURCE_DIR@', '@OUTDIR@'],
- env : {'FLASHROM_VERSION' : meson.project_version() },
+ command : [sphinx, '-b', 'man', '-q', '-d', '@PRIVATE_DIR@', '-Drelease=' + meson.project_version(),'@CURRENT_SOURCE_DIR@', '@OUTDIR@'],
build_always_stale : true, # sphinx handles rebuilds
output : man_outputs,
install : true,
@@ -26,8 +25,7 @@ if sphinx.found()
if get_option('documentation').auto() or get_option('documtation').enabled()
custom_target(
'documentation',
- command : [sphinx, '-b', 'html', '-q', '-d', '@PRIVATE_DIR@', '@CURRENT_SOURCE_DIR@', '@OUTDIR@/html'],
- env : {'FLASHROM_VERSION' : meson.project_version() },
+ command : [sphinx, '-b', 'html', '-q', '-d', '@PRIVATE_DIR@', '-Drelease=' + meson.project_version(),'@CURRENT_SOURCE_DIR@', '@OUTDIR@/html'],
build_always_stale : true, # sphinx handles rebuilds
output : 'html',
install : true,