summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlitghost <537074+litghost@users.noreply.github.com>2021-02-15 09:15:55 -0800
committerGitHub <noreply@github.com>2021-02-15 09:15:55 -0800
commitf2e62c3a0e082111d27e59699ce9caf196aa8be6 (patch)
treea1bfc27900106e2dd7d93629313f9809429b4cee
parent17ab90f8cd3f3407ebbcd8be946e25bac22488db (diff)
parent7c2a95dadffb001629ca975604e65b74fd683987 (diff)
downloadfpga-interchange-schema-f2e62c3a0e082111d27e59699ce9caf196aa8be6.tar.gz
fpga-interchange-schema-f2e62c3a0e082111d27e59699ce9caf196aa8be6.tar.bz2
fpga-interchange-schema-f2e62c3a0e082111d27e59699ce9caf196aa8be6.zip
Merge pull request #7 from litghost/fix_interface_path
Add INTERFACE path to library.
-rw-r--r--cmake/cxx_static/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/cmake/cxx_static/CMakeLists.txt b/cmake/cxx_static/CMakeLists.txt
index 99c9482..e5cfecb 100644
--- a/cmake/cxx_static/CMakeLists.txt
+++ b/cmake/cxx_static/CMakeLists.txt
@@ -32,4 +32,5 @@ add_library(fpga_interchange_capnp STATIC ${CAPNP_SRCS})
add_dependencies(fpga_interchange_capnp get_java_capnp_schema)
target_link_libraries(fpga_interchange_capnp PRIVATE CapnProto::capnp)
-set(FPGA_INTERCHANGE_CAPNP_INCLUDE_DIR ${CMAKE_CURRENT_BINARY_DIR}/../../interchange)
+get_filename_component(FPGA_INTERCHANGE_CAPNP_INCLUDE_DIR "${CMAKE_CURRENT_BINARY_DIR}/../../interchange" ABSOLUTE)
+target_include_directories(fpga_interchange_capnp INTERFACE ${FPGA_INTERCHANGE_CAPNP_INCLUDE_DIR})