summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlitghost <537074+litghost@users.noreply.github.com>2021-03-22 15:40:01 -0700
committerGitHub <noreply@github.com>2021-03-22 15:40:01 -0700
commitf537a57fd7af091aabb776cb888f103b2b29349b (patch)
tree1c92af1c0998f7b916c46d3a0f32885f1c7fa54d
parent1d8255b2f654ae0999b3c0eabf542aaa37324370 (diff)
parent8ec5b1739d7b91b84df3e92ccc70c7a7ee644089 (diff)
downloadfpga-interchange-schema-f537a57fd7af091aabb776cb888f103b2b29349b.tar.gz
fpga-interchange-schema-f537a57fd7af091aabb776cb888f103b2b29349b.tar.bz2
fpga-interchange-schema-f537a57fd7af091aabb776cb888f103b2b29349b.zip
Merge pull request #20 from litghost/add_missing_stuff
Add DeviceResources to cxx_static Makefile and C++ namespace.
-rw-r--r--cmake/cxx_static/CMakeLists.txt2
-rw-r--r--interchange/DeviceResources.capnp3
2 files changed, 4 insertions, 1 deletions
diff --git a/cmake/cxx_static/CMakeLists.txt b/cmake/cxx_static/CMakeLists.txt
index 5e7489f..196c328 100644
--- a/cmake/cxx_static/CMakeLists.txt
+++ b/cmake/cxx_static/CMakeLists.txt
@@ -1,5 +1,5 @@
find_package(CapnProto REQUIRED)
-set(PROTOS LogicalNetlist.capnp PhysicalNetlist.capnp References.capnp)
+set(PROTOS LogicalNetlist.capnp PhysicalNetlist.capnp DeviceResources.capnp References.capnp)
set(INTERCHANGE_SCHEMA_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../interchange)
diff --git a/interchange/DeviceResources.capnp b/interchange/DeviceResources.capnp
index 9540f3f..94dd797 100644
--- a/interchange/DeviceResources.capnp
+++ b/interchange/DeviceResources.capnp
@@ -19,6 +19,9 @@ using Dir = import "LogicalNetlist.capnp";
$Java.package("com.xilinx.rapidwright.interchange");
$Java.outerClassname("DeviceResources");
+using Cxx = import "/capnp/c++.capnp";
+$Cxx.namespace("DeviceResources");
+
struct HashSet {
type @0 : Ref.ImplementationType = enumerator;
hide @1 : Bool = true;