summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cmake/cxx_static/CMakeLists.txt2
-rw-r--r--interchange/DeviceResources.capnp3
2 files changed, 4 insertions, 1 deletions
diff --git a/cmake/cxx_static/CMakeLists.txt b/cmake/cxx_static/CMakeLists.txt
index 5e7489f..196c328 100644
--- a/cmake/cxx_static/CMakeLists.txt
+++ b/cmake/cxx_static/CMakeLists.txt
@@ -1,5 +1,5 @@
find_package(CapnProto REQUIRED)
-set(PROTOS LogicalNetlist.capnp PhysicalNetlist.capnp References.capnp)
+set(PROTOS LogicalNetlist.capnp PhysicalNetlist.capnp DeviceResources.capnp References.capnp)
set(INTERCHANGE_SCHEMA_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../interchange)
diff --git a/interchange/DeviceResources.capnp b/interchange/DeviceResources.capnp
index 9540f3f..94dd797 100644
--- a/interchange/DeviceResources.capnp
+++ b/interchange/DeviceResources.capnp
@@ -19,6 +19,9 @@ using Dir = import "LogicalNetlist.capnp";
$Java.package("com.xilinx.rapidwright.interchange");
$Java.outerClassname("DeviceResources");
+using Cxx = import "/capnp/c++.capnp";
+$Cxx.namespace("DeviceResources");
+
struct HashSet {
type @0 : Ref.ImplementationType = enumerator;
hide @1 : Bool = true;