aboutsummaryrefslogtreecommitdiffstats
path: root/icezum/pushbutton_and/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icezum/pushbutton_and/Makefile')
-rw-r--r--icezum/pushbutton_and/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/icezum/pushbutton_and/Makefile b/icezum/pushbutton_and/Makefile
new file mode 100644
index 0000000..2042685
--- /dev/null
+++ b/icezum/pushbutton_and/Makefile
@@ -0,0 +1,32 @@
+PROJ = pushbutton_and
+PIN_DEF = $(PROJ).pcf
+DEVICE = hx1k
+
+all: $(PROJ).rpt $(PROJ).bin
+
+%.blif: %.vhdl
+ ghdl -a $(PROJ).vhdl
+ yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
+
+
+%.asc: $(PIN_DEF) %.blif
+ arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
+
+%.bin: %.asc
+ icepack $< $@
+
+%.rpt: %.asc
+ icetime -d $(DEVICE) -mtr $@ $<
+
+prog: $(PROJ).bin
+ iceprog $<
+
+sudo-prog: $(PROJ).bin
+ @echo 'Executing prog as root!!!'
+ sudo iceprog $<
+
+clean:
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
+
+.SECONDARY:
+.PHONY: all prog clean