aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--src/grt/Makefile.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index 860c91344..6e4b741e0 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -153,8 +153,8 @@ grt/run-bind.o: grt grt/run-bind.adb
grt/main.o: grt $(GRTSRCDIR)/main.adb
cd grt && $(MSYS2_ARG) $(GRT_ADACOMPILE) -o main.o $(GRTSRCDIR)/main.adb -Igrt
-GRT_C_COMPILE = $(CC) -c $(GRT_FLAGS) -o $@ $<
-GRT_C_COMPILE_PIC = $(CC) -c $(GRT_FLAGS) $(PIC_FLAGS) -o $@ $<
+GRT_C_COMPILE = $(CC) -c $(GRT_FLAGS) $(CFLAGS) -o $@ $<
+GRT_C_COMPILE_PIC = $(CC) -c $(GRT_FLAGS) $(PIC_FLAGS) $(CFLAGS) -o $@ $<
jumps.o: $(GRTSRCDIR)/config/jumps.c
$(GRT_C_COMPILE)