aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pyGHDL/requirements.txt2
-rw-r--r--setup.py10
2 files changed, 5 insertions, 7 deletions
diff --git a/pyGHDL/requirements.txt b/pyGHDL/requirements.txt
index 54944c996..4fe037972 100644
--- a/pyGHDL/requirements.txt
+++ b/pyGHDL/requirements.txt
@@ -1,3 +1,3 @@
pydecor>=2.0.1
#pyVHDLModel==0.10.2
-git+https://github.com/VHDL/pyVHDLModel.git@dev#pyVHDLModel
+https://github.com/VHDL/pyVHDLModel/archive/dev.zip#pyVHDLModel
diff --git a/setup.py b/setup.py
index 32acf3456..330247011 100644
--- a/setup.py
+++ b/setup.py
@@ -64,11 +64,9 @@ def get_requirements(file: Path) -> List[str]:
for line in fh.readlines():
if line.startswith("#"):
continue
- elif line.startswith("git+"):
- _splitItems = line.split("#")
- requirements.append(
- "{} @ {}".format(_splitItems[1].strip(), _splitItems[0])
- )
+ elif line.startswith("https"):
+ _splitItems = line.strip().split("#")
+ requirements.append("{} @ {}".format(_splitItems[1], _splitItems[0]))
else:
requirements.append(line.strip())
return requirements
@@ -135,7 +133,7 @@ setuptools_setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Development Status :: 4 - Beta",
- # "Development Status :: 5 - Production/Stable",
+ # "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"Topic :: Scientific/Engineering :: Electronic Design Automation (EDA)",
"Topic :: Software Development :: Code Generators",