aboutsummaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Makefile.inc20
-rw-r--r--libraries/openieee/math_real-body.vhdl19
-rw-r--r--libraries/openieee/math_real.vhdl19
-rw-r--r--libraries/openieee/numeric_bit-body.proto19
-rw-r--r--libraries/openieee/numeric_bit.proto19
-rw-r--r--libraries/openieee/numeric_common.proto19
-rw-r--r--libraries/openieee/numeric_std-body.proto19
-rw-r--r--libraries/openieee/numeric_std.proto19
-rw-r--r--libraries/openieee/std_logic_1164-body.proto19
-rw-r--r--libraries/openieee/std_logic_1164.proto19
-rw-r--r--libraries/openieee/v08/std_logic_1164-body.vhdl19
-rw-r--r--libraries/openieee/v08/std_logic_1164.vhdl19
-rw-r--r--libraries/openieee/v87/numeric_bit-body.vhdl19
-rw-r--r--libraries/openieee/v87/numeric_bit.vhdl19
-rw-r--r--libraries/openieee/v87/numeric_std-body.vhdl19
-rw-r--r--libraries/openieee/v87/numeric_std.vhdl19
-rw-r--r--libraries/openieee/v87/std_logic_1164-body.vhdl19
-rw-r--r--libraries/openieee/v87/std_logic_1164.vhdl19
-rw-r--r--libraries/openieee/v93/numeric_bit-body.vhdl19
-rw-r--r--libraries/openieee/v93/numeric_bit.vhdl19
-rw-r--r--libraries/openieee/v93/numeric_std-body.vhdl19
-rw-r--r--libraries/openieee/v93/numeric_std.vhdl19
-rw-r--r--libraries/openieee/v93/std_logic_1164-body.vhdl19
-rw-r--r--libraries/openieee/v93/std_logic_1164.vhdl19
-rw-r--r--libraries/std/env-body.vhdl20
-rw-r--r--libraries/std/env.vhdl20
-rw-r--r--libraries/vendors/compile-osvvm.ps12
27 files changed, 235 insertions, 264 deletions
diff --git a/libraries/Makefile.inc b/libraries/Makefile.inc
index 0c71d9437..941776c29 100644
--- a/libraries/Makefile.inc
+++ b/libraries/Makefile.inc
@@ -1,20 +1,18 @@
# -*- Makefile -*- for the VHDL libraries.
# Copyright (C) 2002, 2003, 2004, 2005 Tristan Gingold
#
-# GHDL is free software; you can redistribute it and/or modify it under
-# the terms of the GNU General Public License as published by the Free
-# Software Foundation; either version 2, or (at your option) any later
-# version.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with GCC; see the file COPYING. If not, write to the Free
-# Software Foundation, 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
+# along with this program. If not, see <gnu.org/licenses>.
# Variable to be defined:
# LIBSRC_DIR: path to the libraries sources
diff --git a/libraries/openieee/math_real-body.vhdl b/libraries/openieee/math_real-body.vhdl
index 782444b12..fa21d9a4f 100644
--- a/libraries/openieee/math_real-body.vhdl
+++ b/libraries/openieee/math_real-body.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.2 math_real package body.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body MATH_REAL is
function SIGN (X : REAL) return REAL is
diff --git a/libraries/openieee/math_real.vhdl b/libraries/openieee/math_real.vhdl
index b84748a9d..53b4887b0 100644
--- a/libraries/openieee/math_real.vhdl
+++ b/libraries/openieee/math_real.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.2 math_real package.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package MATH_REAL is
-- The values were computed with at least 40 digits and rounded to
diff --git a/libraries/openieee/numeric_bit-body.proto b/libraries/openieee/numeric_bit-body.proto
index 47d2569cd..36beb4904 100644
--- a/libraries/openieee/numeric_bit-body.proto
+++ b/libraries/openieee/numeric_bit-body.proto
@@ -3,19 +3,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_BIT is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/numeric_bit.proto b/libraries/openieee/numeric_bit.proto
index 9443751ea..6e6a7a078 100644
--- a/libraries/openieee/numeric_bit.proto
+++ b/libraries/openieee/numeric_bit.proto
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric bit package.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package NUMERIC_BIT is
type UNSIGNED is array (natural range <>) of BIT;
diff --git a/libraries/openieee/numeric_common.proto b/libraries/openieee/numeric_common.proto
index ab426bc8b..517dd84de 100644
--- a/libraries/openieee/numeric_common.proto
+++ b/libraries/openieee/numeric_common.proto
@@ -2,19 +2,18 @@
-- Common part of numeric_bit and numeric_std defined by IEEE 1076.3
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
function TO_INTEGER (ARG : UNSIGNED) return NATURAL;
function TO_INTEGER (ARG : SIGNED) return INTEGER;
diff --git a/libraries/openieee/numeric_std-body.proto b/libraries/openieee/numeric_std-body.proto
index f38584c9e..9a5802440 100644
--- a/libraries/openieee/numeric_std-body.proto
+++ b/libraries/openieee/numeric_std-body.proto
@@ -3,19 +3,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_STD is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/numeric_std.proto b/libraries/openieee/numeric_std.proto
index 426db8752..02e96b303 100644
--- a/libraries/openieee/numeric_std.proto
+++ b/libraries/openieee/numeric_std.proto
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric std package.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
library IEEE;
use IEEE.STD_LOGIC_1164.all;
diff --git a/libraries/openieee/std_logic_1164-body.proto b/libraries/openieee/std_logic_1164-body.proto
index b5f724e26..dd5879bdc 100644
--- a/libraries/openieee/std_logic_1164-body.proto
+++ b/libraries/openieee/std_logic_1164-body.proto
@@ -2,19 +2,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
-- This is a template file. To avoid errors and duplication, the python
-- script build.py generate most of the bodies.
diff --git a/libraries/openieee/std_logic_1164.proto b/libraries/openieee/std_logic_1164.proto
index 95c6f5c83..0b1665075 100644
--- a/libraries/openieee/std_logic_1164.proto
+++ b/libraries/openieee/std_logic_1164.proto
@@ -2,19 +2,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015-2021 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GHDL; see the file COPYING.md. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
use std.textio.all; --V08
--V08
diff --git a/libraries/openieee/v08/std_logic_1164-body.vhdl b/libraries/openieee/v08/std_logic_1164-body.vhdl
index 25e219c2e..ec473eb99 100644
--- a/libraries/openieee/v08/std_logic_1164-body.vhdl
+++ b/libraries/openieee/v08/std_logic_1164-body.vhdl
@@ -3,19 +3,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
-- This is a template file. To avoid errors and duplication, the python
-- script build.py generate most of the bodies.
diff --git a/libraries/openieee/v08/std_logic_1164.vhdl b/libraries/openieee/v08/std_logic_1164.vhdl
index 8271b1b93..8df4cdcde 100644
--- a/libraries/openieee/v08/std_logic_1164.vhdl
+++ b/libraries/openieee/v08/std_logic_1164.vhdl
@@ -2,19 +2,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
use std.textio.all;
diff --git a/libraries/openieee/v87/numeric_bit-body.vhdl b/libraries/openieee/v87/numeric_bit-body.vhdl
index 63551d264..adbaf9997 100644
--- a/libraries/openieee/v87/numeric_bit-body.vhdl
+++ b/libraries/openieee/v87/numeric_bit-body.vhdl
@@ -4,19 +4,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_BIT is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/v87/numeric_bit.vhdl b/libraries/openieee/v87/numeric_bit.vhdl
index 6a6dcc393..ec13d636a 100644
--- a/libraries/openieee/v87/numeric_bit.vhdl
+++ b/libraries/openieee/v87/numeric_bit.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric bit package.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package NUMERIC_BIT is
type UNSIGNED is array (natural range <>) of BIT;
diff --git a/libraries/openieee/v87/numeric_std-body.vhdl b/libraries/openieee/v87/numeric_std-body.vhdl
index 6942bd4e1..19bbf7b7b 100644
--- a/libraries/openieee/v87/numeric_std-body.vhdl
+++ b/libraries/openieee/v87/numeric_std-body.vhdl
@@ -4,19 +4,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_STD is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/v87/numeric_std.vhdl b/libraries/openieee/v87/numeric_std.vhdl
index e1fa946ca..7b0f10cc5 100644
--- a/libraries/openieee/v87/numeric_std.vhdl
+++ b/libraries/openieee/v87/numeric_std.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric std package.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
library IEEE;
use IEEE.STD_LOGIC_1164.all;
diff --git a/libraries/openieee/v87/std_logic_1164-body.vhdl b/libraries/openieee/v87/std_logic_1164-body.vhdl
index b6dd265d0..951b6a525 100644
--- a/libraries/openieee/v87/std_logic_1164-body.vhdl
+++ b/libraries/openieee/v87/std_logic_1164-body.vhdl
@@ -3,19 +3,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
-- This is a template file. To avoid errors and duplication, the python
-- script build.py generate most of the bodies.
diff --git a/libraries/openieee/v87/std_logic_1164.vhdl b/libraries/openieee/v87/std_logic_1164.vhdl
index 67e63dac5..000657044 100644
--- a/libraries/openieee/v87/std_logic_1164.vhdl
+++ b/libraries/openieee/v87/std_logic_1164.vhdl
@@ -2,19 +2,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package std_logic_1164 is
diff --git a/libraries/openieee/v93/numeric_bit-body.vhdl b/libraries/openieee/v93/numeric_bit-body.vhdl
index f9ce50b2b..3c31f4093 100644
--- a/libraries/openieee/v93/numeric_bit-body.vhdl
+++ b/libraries/openieee/v93/numeric_bit-body.vhdl
@@ -4,19 +4,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_BIT is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/v93/numeric_bit.vhdl b/libraries/openieee/v93/numeric_bit.vhdl
index eb21bbc2f..9d60dc9bf 100644
--- a/libraries/openieee/v93/numeric_bit.vhdl
+++ b/libraries/openieee/v93/numeric_bit.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric bit package.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package NUMERIC_BIT is
type UNSIGNED is array (natural range <>) of BIT;
diff --git a/libraries/openieee/v93/numeric_std-body.vhdl b/libraries/openieee/v93/numeric_std-body.vhdl
index ba6b510d6..2436c943b 100644
--- a/libraries/openieee/v93/numeric_std-body.vhdl
+++ b/libraries/openieee/v93/numeric_std-body.vhdl
@@ -4,19 +4,18 @@
-- The implementation is based only on the specifications.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package body NUMERIC_STD is
constant NO_WARNING : Boolean := False;
diff --git a/libraries/openieee/v93/numeric_std.vhdl b/libraries/openieee/v93/numeric_std.vhdl
index 8f58221ee..fbf63e451 100644
--- a/libraries/openieee/v93/numeric_std.vhdl
+++ b/libraries/openieee/v93/numeric_std.vhdl
@@ -2,19 +2,18 @@
-- IEEE 1076.3 compliant numeric std package.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
library IEEE;
use IEEE.STD_LOGIC_1164.all;
diff --git a/libraries/openieee/v93/std_logic_1164-body.vhdl b/libraries/openieee/v93/std_logic_1164-body.vhdl
index af43ba306..a2eee0617 100644
--- a/libraries/openieee/v93/std_logic_1164-body.vhdl
+++ b/libraries/openieee/v93/std_logic_1164-body.vhdl
@@ -3,19 +3,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
-- This is a template file. To avoid errors and duplication, the python
-- script build.py generate most of the bodies.
diff --git a/libraries/openieee/v93/std_logic_1164.vhdl b/libraries/openieee/v93/std_logic_1164.vhdl
index 879a7870b..e512f982d 100644
--- a/libraries/openieee/v93/std_logic_1164.vhdl
+++ b/libraries/openieee/v93/std_logic_1164.vhdl
@@ -2,19 +2,18 @@
-- on the specifications. This file is part of GHDL.
-- Copyright (C) 2015 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING2. If not see
--- <http://www.gnu.org/licenses/>.
+-- along with this program. If not, see <gnu.org/licenses>.
package std_logic_1164 is
diff --git a/libraries/std/env-body.vhdl b/libraries/std/env-body.vhdl
index d36519fc9..c1b8e9c76 100644
--- a/libraries/std/env-body.vhdl
+++ b/libraries/std/env-body.vhdl
@@ -2,20 +2,18 @@
-- This file was written from the clause 14.3 of the VHDL LRM.
-- Copyright (C) 2014 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING. If not, write to the Free
--- Software Foundation, 59 Temple Place - Suite 330, Boston, MA
--- 02111-1307, USA.
+-- along with this program. If not, see <gnu.org/licenses>.
package body Env is
procedure control_simulation (Is_Stop : Boolean;
diff --git a/libraries/std/env.vhdl b/libraries/std/env.vhdl
index 35cbb0261..ad17521e5 100644
--- a/libraries/std/env.vhdl
+++ b/libraries/std/env.vhdl
@@ -2,20 +2,18 @@
-- This file was written from the clause 14.3 of the VHDL LRM.
-- Copyright (C) 2014 Tristan Gingold
--
--- GHDL is free software; you can redistribute it and/or modify it under
--- the terms of the GNU General Public License as published by the Free
--- Software Foundation; either version 2, or (at your option) any later
--- version.
+-- This program is free software: you can redistribute it and/or modify
+-- it under the terms of the GNU General Public License as published by
+-- the Free Software Foundation, either version 2 of the License, or
+-- (at your option) any later version.
--
--- GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
--- WARRANTY; without even the implied warranty of MERCHANTABILITY or
--- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
--- for more details.
+-- This program is distributed in the hope that it will be useful,
+-- but WITHOUT ANY WARRANTY; without even the implied warranty of
+-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
--- along with GCC; see the file COPYING. If not, write to the Free
--- Software Foundation, 59 Temple Place - Suite 330, Boston, MA
--- 02111-1307, USA.
+-- along with this program. If not, see <gnu.org/licenses>.
package Env is
procedure Stop (Status : Integer);
diff --git a/libraries/vendors/compile-osvvm.ps1 b/libraries/vendors/compile-osvvm.ps1
index f11876bc5..cdaf9f059 100644
--- a/libraries/vendors/compile-osvvm.ps1
+++ b/libraries/vendors/compile-osvvm.ps1
@@ -148,7 +148,7 @@ if ((-not $StopCompiling) -and $OSVVM)
)
$SourceFiles = $Files | % { "$SourceDirectory\$_" }
- $ErrorCount += 0
+ $ErrorCount += 0
Start-PackageCompilation $GHDLBinary $GHDLOptions $DestinationDirectory $Library $VHDLVersion $SourceFiles $SuppressWarnings $HaltOnError -Verbose:$EnableVerbose -Debug:$EnableDebug
$StopCompiling = $HaltOnError -and ($ErrorCount -ne 0)
}